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FOREWORD 
 

NX is one of the world’s most advanced and tightly integrated CAD/CAM/CAE product 

development solutions. Spanning the entire range of product development, NX delivers immense 

value to enterprises of all sizes. It simplifies complex product designs, thus speeding up the 

process of introducing products to the market.   

The NX software integrates knowledge-based principles, industrial design, geometric modeling, 

advanced analysis, graphic simulation, and concurrent engineering. The software has powerful 

hybrid modeling capabilities by integrating constraint-based feature modeling and explicit 

geometric modeling. In addition to modeling standard geometry parts, it allows the user to design  

complex free-form shapes such as airfoils and manifolds.  It also merges solid and surface 

modeling techniques into one powerful tool set. 

 

This self-guiding tutorial provides a step-by-step approach for users to learn NX7.  It is intended 

for those with no previous experience with NX. However, users of previous versions of NX may 

also find this tutorial useful for them to learn the new user interfaces and functions. The user will 

be guided from starting a NX7 session to creating models and designs that have various 

applications. Each chapter has components explained with the help of various dialog boxes and 

screen images. These components are later used in the assembly modeling, machining and finite 

element analysis. These models of components are available online to download and use. We 

first released the tutorial for Unigraphics 18 and later updated for NX2 followed by the updates 

for NX3 and NX5. This write-up further updates to NX7. 

  

Our previous efforts to prepare the NX self-guiding tutorial were funded by the National Science 

Foundation’s Advanced Technological Education Program and by the Partners of the 

Advancement of Collaborative Engineering Education (PACE) program 

  

If you have any questions or comments about this tutorial, please email Ming C. Leu at 

mleu@mst.edu or Krishna C. R. Kolan at kkd7b@mail.mst.edu. The models and all the versions 

of the tutorial are available at http://web.mst.edu/~mleu/. 
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CHAPTER 1 - INTRODUCTION 
 

The modern manufacturing environment can be characterized by the paradigm of delivering 
products of increasing variety, smaller batches and higher quality in the context of increasing 
global competition. Industries cannot survive worldwide competition unless they introduce new 
products with better quality, at lower costs and with shorter lead-time. There is intense 
international competition and decreased availability of skilled labor. With dramatic changes in 
computing power and wider availability of software tools for design and production, engineers 
are now using Computer Aided Design (CAD), Computer Aided Manufacturing (CAM) and 
Computer Aided Engineering (CAE) systems to automate their design and production processes. 
These technologies are now used every day for sorts of different engineering tasks. Below is a 
brief description of how CAD, CAM, and CAE technologies are being used during the product 
realization process. 

 

1.1 PRODUCT REALIZATION PROCESS 
 

The product realization process can be roughly divided into two phases; design and 
manufacturing. The design process starts with identification of new customer needs and design 
variables to be improved, which are identified by the marketing personnel after getting feedback 
from the customers. Once the relevant design information is gathered, design specifications are 
formulated. A feasibility study is conducted with relevant design information and detailed design 
and analyses are performed. The detailed design includes design conceptualization, prospective 
product drawings, sketches and geometric modeling. Analysis includes stress analysis, 
interference checking, kinematics analysis, mass property calculations and tolerance analysis, 
and design optimization. The quality of the results obtained from these activities is directly 
related to the quality of the analysis and the tools used for conducting the analysis. 
 
The manufacturing process starts with the shop-floor activities beginning from production 
planning, which uses the design process drawings and ends with the actual product. Process 
planning includes activities like production planning, material procurement, and machine 
selection. There are varied tasks like procurement of new tools, NC programming and quality 
checks at various stages during the production process. Process planning includes planning for 
all the processes used in manufacturing of the product. Parts that pass the quality control 
inspections are assembled functionally tested, packaged, labeled, and shipped to customers. 
 
A diagram representing the Product Realization Process (Mastering CAD/CAM, by Ibrahim Zeid, 
McGraw Hill, 2005) is shown below. 
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1.2 BRIEF HISTORY OF CAD
 

The roots of current CAD/CAM technologies go back to the beginning of civilization when 
engineers in ancient Egypt recognized graphics communication. Orthographic projection 
practiced today was invented around the 1800’s. The real development of CAD/CAM sy
started in the 1950s. CAD/CAM went through four major phases of development in the last 
century. The 1950’s was known as the era of interactive computer graphics. MIT’s Servo 
Mechanisms Laboratory demonstrated the concept of numerical control (NC) on
milling machine. Development in this era was slowed down by the shortcomings of computers at 
the time. During the late 1950’s the development of Automatically Programmed Tools (APT) 
began and General Motors explored the potential of interacti
 
The 1960s was the most critical research period for interactive computer graphics. Ivan 
Sutherland developed a sketchpad system, which demonstrated the possibility of creating 
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drawings and altercations of objects interactively on a cathode ray tube (CRT). The term CAD 
started to appear with the word ‘design’ extending beyond basic drafting concepts. General 
Motors announced their DAC-1 system and Bell Technologies introduced the GRAPHIC 1 
remote display system.  
 
During the 1970’s, the research efforts of the previous decade in computer graphics had begun to 
be fruitful, and potential of interactive computer graphics in improving productivity was realized 
by industry, government and academia. The 1970’s is characterized as the golden era for 
computer drafting and the beginning of ad hoc instrumental design applications.  National 
Computer Graphics Association (NCGA) was formed and Initial Graphics Exchange 
Specification (IGES) was initiated.  
 
In the 1980’s, new theories and algorithms evolved and integration of various elements of design 
and manufacturing was developed. The major research and development focus was to expand 
CAD/CAM systems beyond three-dimensional geometric designs and provide more engineering 
applications. 
 
The present day CAD/CAM development focuses on efficient and fast integration and 
automation of various elements of design and manufacturing along with the development of new 
algorithms. There are many commercial CAD/CAM packages available for direct usages that are 
user-friendly and very proficient.  
 
Below are some of the commercial packages in the present market. 

• AutoCAD and Mechanical Desktop are some low-end CAD software systems, which are 
mainly used for 2D modeling and drawing. 

 

• NX, Pro-E, CATIA and I-DEAS are high-end modeling and designing software systems 
that are costlier but more powerful. These software systems also have computer aided 
manufacturing and engineering analysis capabilities. 

 

• ANSYS, ABAQUS, NASTRAN, Fluent and CFX are packages mainly used for analysis 
of structures and fluids. Different software are used for different proposes. For example, 
Fluent is used for fluids and ANSYS is used for structures.  

 

• Alibre and CollabCAD are some of the latest CAD systems that focus on collaborative 
design, enabling multiple users of the software to collaborate on computer-aided design 
over the Internet. 
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1.3 DEFINITION OF CAD/CAM/CAE 
 

Following are the definitions of some of the terms used in this tutorial. 

 
1.3.1 Computer Aided Design – CAD 
 

CAD is technology concerned with using computer systems to assist in the creation, 
modification, analysis, and optimization of a design. Any computer program that embodies 
computer graphics and an application program facilitating engineering functions in design 
process can be classified as CAD software. 
 
The most basic role of CAD is to define the geometry of design – a mechanical part, a product 
assembly, an architectural structure, an electronic circuit, a building layout, etc. The greatest 
benefits of CAD systems are that they can save considerable time and reduce errors caused by 
otherwise having to redefine the geometry of the design from scratch every time it is needed. 
 
1.3.2 Computer Aided Manufacturing – CAM 
 

CAM technology involves computer systems that plan, manage, and control the manufacturing 
operations through computer interface with the plant’s production resources.   
 
One of the most important areas of CAM is numerical control (NC). This is the technique of 
using programmed instructions to control a machine tool, which cuts, mills, grinds, punches or 
turns raw stock into a finished part. Another significant CAM function is in the programming of 
robots. Process planning is also a target of computer automation. 
 
1.3.3 Computer Aided Engineering – CAE 
 

CAE technology uses a computer system to analyze the functions of a CAD-created product, 
allowing designers to simulate and study how the product will behave so that the design can be 
refined and optimized.  
 
CAE tools are available for a number of different types of analyses. For example, kinematic 
analysis programs can be used to determine motion paths and linkage velocities in mechanisms. 
Dynamic analysis programs can be used to determine loads and displacements in complex 
assemblies such as automobiles. One of the most popular methods of analyses is using a Finite 
Element Method (FEM). This approach can be used to determine stress, deformation, heat 
transfer, magnetic field distribution, fluid flow, and other continuous field problems that are 
often too tough to solve with any other approach. 
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1.4 SCOPE OF THIS TUTORIAL 
 
This tutorial is written for students and engineers who are interested in learning how to use NX7 
for designing mechanical components and assemblies. Learning to use this software will also be 
valuable for learning how to use other CAD systems such as PRO-E and CATIA. 
 
This tutorial provides a step-by-step approach for learning NX7. The topics include Getting 
Started with NX7, Form Features, Feature Operations, Drafting, Sketching, Free Form Features, 
Assembly Modeling, and Manufacturing.  
 
Chapter 1 gives the overview of CAD/CAM/CAE. The product realization cycle is discussed 
along with the history of CAD/CAM/CAE and the definitions of each.  
 
Chapter 2 includes the NX7 essentials from starting a session with Windows to getting familiar 
with the NX7 layout by practicing basic functions such as Print, Save, and Exit. It also gives a 
brief description of the Coordinate System, Layers, various toolboxes and other important 
commands, which will be used in later chapters.   
The actual designing and modeling of parts begins with chapter 3. It describes different features 
such as reference features, swept features and primitive features and how these features are used 
to create designs. 
  
Chapter 4 is a continuation of chapter 3 where various kinds of feature operations are performed 
on features. The different kinds of operations include Trim, Blend, Boolean operations and many 
more. 
 
You will learn how to create a drawing from a part model in chapter 5. In this chapter, we 
demonstrate how to create a drawing by adding views, dimensioning the part drawings, and 
modifying various attributes in the drawing such as text size, arrow size and tolerance.  
 
Chapter 6 presents the concept of sketching. It describes how to create sketches and to give 
geometric and dimensional constraints. This chapter is very important since present-day 
components are very complex in geometry and difficult to model with only basic features. 
 
Chapter 7 introduces free-form modeling. The method of modeling curves and smooth surfaces 
will be demonstrated.  
 
Chapter 8 teaches the concepts of Assembly Modeling and its terminologies. It describes Top-
Down modeling and Bottom-Up modeling. We will use Bottom-Up modeling to assemble 
components into a product. 
 
Chapter 9 will be a real-time experience of implementing a designed model into a manufacturing 
environment for machining. This chapter deals with generation, verification and simulation of 
Tool Path to create CNC (Computer Numerical Codes) to produce the designed parts from 
Vertical Machining Centers.  
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Chapter 10 is capsulated into a brief introduction to Structures Module available in NX7 for the 
Finite Element Modeling and Analysis.  
 
The examples and exercise problems used in each chapter are so designed that they will be 
finally assembled in the chapter. Due to this distinctive feature, you should save all the models 
that you have generated in each chapter. 
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CHAPTER 2 - GETTING STARTED  
 

We begin with starting of an NX7 session. This chapter will provide the basics required to use 
any CAD/CAM package. You will learn the preliminary steps to start, to understand and to use 
the NX7 package for modeling, drafting, etc. It contains five sub-sections a) Opening an NX7 
session, b) Printing, saving, and closing part files, c) getting acquainted with the NX7 user 
interface d) Using layers and e) Understanding important commands & dialogs. 
 

2.1 STARTING NX7 SESSION AND OPENING FILES 
 

2.1.1 Open NX7 Session 
 

� From the Windows desktop screen, click on Start → Programs → UGS NX 7.5 → NX 7.5 
 

 

 
The main NX7 Screen will open. This is the Gateway for the NX7 software. The NX7 blank 
screen looks like the figure shown below. There will be different tips displayed on the screen 
about the special features of the current version. The Gateway also has the Standard Toolbar that 
will allow you to create a new file or open an existing file. On the left side of the Gateway 
screen, there is a Toolbar called as Resource Bar that has menus related to different modules 
and the ability to define and change the ‘Role’ of the software, view ‘History’ of the software use 
and so on. This will be explained in detail later in this chapter. Let’s begin by learning how to 
open a part file in NX7. 
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To create a new file there are two options. You can click on the ‘New’ tab on top of the screen or 
go through the ‘File’ drop-down menu. 
 

 

 

2.1.2 Open a New File 
 

� On the menu bar found at the top-left of the screen, click FILE ���� NEW 
  

This will open a new session, asking for the name and location of the new file to be created as 

shown at the bottom left. You need to select the units (inches or millimeters) of the working 

environment by clicking on the drop-down menu on the top right corner. The default is 

millimeters. However, most of the material in the tutorials is modeled in inches. So always, be 

sure to select inches before creating a new .prt file unless otherwise specified.  You can also 

select the type of the file you want to create – either a part file or an assembly file or sheet-metal 

file – by selecting the file type as shown in Templates dialogue box located at the center of the 
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window. The properties of the selected file are displayed below the Preview on the middle right 

corner.  

� Enter the location of the file and then and click OK 
 

 

 

2.1.3 Open a Part File 
 

� Click FILE → OPEN  
 
You can also click the Open icon from the Standard toolbar at the top of the screen.  
 
The Open Part File dialog will appear. You can see the preview of the files on the right side of 
the window. You can disable the Preview by un-clicking the box in front of the Preview button. 
 
� Click CANCEL to exit the window  
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2.2 PRINTING, SAVING AND CLOSING PART FILES 
 

2.2.1 Print a NX7 Image  
 

� Click FILE → PRINT 
 

You can also click the Print icon on the Standard  
Toolbar. The following figure shows the Print dialog box. 
Here, you can choose the printer to use or specify the 
number of copies to be printed, size of the paper and so 
on. 
You can also select the scale for all the three dimensions. 
You can also choose the method of printing, i.e. 
wireframe, solid model by clicking on the ‘Output’ drop 
down-menu as shown in the Figure on right side 
 
� Click CANCEL to exit the window 
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2.2.2 Save Part Files 
 

It is imperative that you save your work very frequently. If 
for some reasons, NX7 shuts down and the part is not saved, 
all the work will be lost. To save the part files 
 
� Click FILE 
 
On the File drop-down menu, there are five different options 
to save a file. 

• SAVE: This option will save the part on screen with 
the same name as given before while creating the part 
file. 

• SAVE WORK PART ONLY: option will only save the 
active part on the screen. 

• SAVE AS: option allows you to save the part on screen using a different name. 

• SAVE ALL: This option will save all the opened part files with their existing names. 

• SAVE BOOKMARK: This option will save a screenshot of the current model on the 
screen as a .JPEG file and bookmarks. 

 
Remember as in previous versions all the parts are saved with a .prt extension in NX7. 
 
2.2.3 Close Part Files 

 

You can choose to close the parts that are visible on screen by  

 
� Click FILE → CLOSE 
 
If you close a file, the file will be cleared from the working memory and any changes that are not 
saved will be lost. Therefore, remember to select SAVE AND CLOSE or SAVE ALL AND 

CLOSE or SAVE ALL AND EXIT. 
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In case of the first two options, the parts that are selected or the all parts the files will be closed 
but the NX7 session keeps on running. 
 
2.2.4 Exit an NX7 Session 
 

� Click FILE → EXIT 
 

 
 

� Since we are not ready to exit NX7, click NO  
 
If you have files open and have made changes to them without saving, the message will ask you 
if you really want to exit. 
 
� Select NO, save the files and then Exit 

 
2.2.5 Simultaneously Saving All Parts and Exiting  
 
A second way to exit NX7 session at the same time save all the files and exit the program is  
 
� Click FILE → CLOSE → SAVE ALL and EXIT 
 
The Save and Exit warning dialog window is shown below.  
 

 
 
� Choose NO or CANCEL  
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2.3 NX7 INTERFACE  
 

The user interface of NX7 is made very simple through the use of different icons. Most of the 

commands can be executed by navigating the mouse around the screen and clicking on the icons. 

The keyboard entries are mostly limited for entering values and naming files.  

 

2.3.1 Mouse Functionality 
 

It is highly recommended to use a three-button mouse or a scroll-mouse while working with 
NX7. The power of mouse buttons and their primary functions are discussed below.   
 
2.3.1.1 Left Mouse Button (MB1): 
 

The MB1 or left mouse button is used for Selection of 
icons, menus, and other entities on the graphic screen. 
Double clicking MB1 on any feature will automatically 
open the Edit Dialog box. 
 
2.3.1.2 Middle Mouse Button (MB2): 
 

The MB2 or middle mouse button or the scroll button 
is used to Rotate the object by pressing, holding and 
dragging. It can be used for Pan and Zoom options in 
combination with other mouse buttons or key buttons. 
If it is a scroll button, the object can be zoomed in and 
out by scrolling. Just clicking the MB2 will execute the 
OK command if any pop-up window or dialog box is 
open.  
 
2.3.1.3 Right Mouse Button (MB3): 
 

MB3 or Right Mouse Button is used to access the user interface 
pop-up menus. You can access the subsequent options that pop up 
depending on the selection mode and Application. The figures 
shown on the right are in Sketch Application. Clicking on MB3 
when a feature is selected will give the options related to that 
feature (Object/Action Menu).  
 
Clicking MB3 and holding the button will display a set of icons 
around the feature. These icons feature the possible commands 
that can be applied to the feature.  
 
Clicking MB3 on graphics screen will pop up the View menu options as shown below. 
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* Note: The functionality of the mouse buttons depends on the Application used. For 
instance, the menus that pop-up in Modeling are different from those in Sketch. 

 

2.3.1.4 Mouse Functionality 
 
The following is the illustration of the mouse buttons used for rotating, panning and zooming in 
or out on the graphic screen. Besides using these different combinations of mouse buttons, the 
following commands can also be performed by icons in the Toolbar.  
 
Rotate:  

� Press and hold the middle mouse button (or scroll button) and drag around the screen to view 
the model in the direction you want. The model can also be rotated about a single axis. To 
rotate about the axis horizontal to the screen, place the mouse pointer near the right edge of 
the graphic screen and rotate. Similarly, for the vertical axis and the axis perpendicular to the 
screen, click at the bottom edge and top edge of the screen respectively and rotate. 

� If you keep pressing the MB2 at the same position for a couple of seconds, it will fix the 
point of rotation (a green + symbol appears) and you can drag around the object to view. 

 

 
 
 



15 
NX7 for Engineering Design                                                                 Missouri University of Science and Technology 

Zoom In /Out: 

� Press and hold both the left mouse button and middle button (or scroll button) simultaneously 
and drag OR 

� Press and hold <Ctrl> button on the keyboard and then press and drag the middle mouse 
button. OR 

� Scroll up and down if the mouse has a scroll wheel. 
 

 
Pan: 

 

� Press and hold both the middle button and right mouse button simultaneously and drag OR 
� Press and hold <Shift> button on the keyboard and press and drag the middle mouse button.  

 

 
 

 
2.3.2 NX7 Gateway  
 
The following figure shows the typical layout of the NX7 window when a file is opened. This is 
the Gateway of NX7 from where you can select any module to work on such as modeling, 
manufacturing, etc. It has to be noted that these toolbars may not be exactly on the same position 
of the screen as shown below. The toolbars can be placed at any location or position on the 
screen. Look out for the same set of icons. 
 



NX7 for Engineering Design                                                                 

 
2.3.2.1 Functions of Gateway Zones
 
Title Bar: 
 

The Title Bar displays the following informa
 

• The name of the currently

• The name of the current work part

• If the work part is read only

• If the work part has been 
 
Menu Bar: 
 

The Menu Bar is the horizontal menu of options displayed at the top of the main window 
directly below the Title Bar. Menu bar

NX functional category. Clicking on a menu title leads to a drop
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Zones 

The Title Bar displays the following information for the current part file. 

ly displayed part 

The name of the current work part 

read only 

If the work part has been modified since it was last saved 

is the horizontal menu of options displayed at the top of the main window 
Menu bar options are called menu titles and each corresponds to a 

Clicking on a menu title leads to a drop-down menu of choices.

Missouri University of Science and Technology 

 

is the horizontal menu of options displayed at the top of the main window 
called menu titles and each corresponds to a 

menu of choices. 
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Toolbar: 
 

A Toolbar is a row of icons that you can use to activate standard NX menu items. NX7 comes 
with a large selection of toolbars. The active Toolbars are located below the Menu bar. The 
toolbars can be placed anywhere on screen by dragging their handles. 
 

 

 
 
If the toolbar handle is dragged to the edges of the screen they attach to that edge of the screen. 
 

Selection Bar: 

The Selection Bar is located below the active Toolbars and displays the selection options. These 
options include the Filters, Components/Assembly, and Snap Points for selecting features. 
 
Resource Bar: 
 

The Resource Bar features icons for a number of pages in one place using very little user 
interface space. NX7 places all navigator windows in the Resource Bar, as well as the History 
Palette, Assembly navigator, Part navigator, Animation navigator, Simulation navigator, Roles 
and the Web Browser. By Default, the Resource Bar is located on the left side of the NX7 
window. You can dock and undock the resource bars by clicking on the pin icon on the top left 
of the resource window.  

 - UNDOCKED         - DOCKED 
Cue Line: 
 

The Cue Line is shown at the top of the main NX window below all the Toolbars. The Cue Line 
displays prompt messages that indicate the next action that needs to be taken.  
 
Status Line: 
 

The Status Line, located to the right of the Cue area, displays information messages about the 
current options or the most recently completed function.  
 

Progress Meter: 
 

The Progress Meter is displayed in the Cue Line when the system performs a time-consuming 
operation such as loading a large assembly. The meter shows the percentage of the operation that 
has been completed. When the operation is finished, the system displays the next appropriate 
cue. 
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2.3.2.2 Part Navigator 
 
� Click on the Part Navigator icon, the second icon 

from the top on the Resource bar 
 
The Part Navigator provides a visual representation of 
the parent-child relationships of features in the work part 
in a separate window in a tree type format. It shows all 
the primitives, entities used during modeling. It allows 
you to perform various editing actions on those features. 
For example, you can use the Part Navigator to suppress 
or un-suppress the features or change their parameters or 
positioning dimensions. Removing the green tick mark 
will ‘Suppress’ the feature. The software will give a 
warning if the parent child relationship is broken by 
suppressing any particular feature. 
  
The Part Navigator is available for all NX applications 
and not just for modeling. However, you can only perform feature-editing operations when you 
are in the Modeling module. Editing a feature in the Part Navigator will automatically update the 
model. Feature editing will be discussed later. 
 
2.3.2.3 History 
 
� Click on the History icon, the fourth from 

the top on the Resource bar 
 
The History Palette provides fast access to 
recently opened files or other palette entries. It 
can be used to reload parts that have been 
recently worked on or to repeatedly add a small 
set of palette items to a model. 
 
The History Palette remembers the last palette 
options that were used and the state of the 
session when it was closed.  NX stores the 
palettes that were loaded into a session and 
restores them in the next session. The system 
does not clean up the History Palette when parts 
are moved.  
 
To re-use a part, drag and drop it from the 
History Palette to the Graphics Window. To reload a part, click on a saved session bookmark. 
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2.3.3 Geometry Selection 
 
Geometry Selection properties are very advanced in NX7. You can filter the selection method, 
which facilitates easy selection of the geometry in a close cluster. In addition, you can perform 
any of the feature operation options that NX7 intelligently provides depending on the selected 
entity.  
 

The Mouse cursor in the Graphics screen will normally be in the shape of a cross hair as 
shown in the figure. Selection of items can be based on the degree of the entity like, 
selection of Geometric entities, Features and Components. The selection method can be 
opted by choosing one of the icons in the Selection Toolbar.  

 
Feature Selection: 
 
Clicking on any of the icons in the figure below will let you select the features in the part file. It 
will not select the basic entities like edges, faces etc. The features selected can also be applied to 
a part or an entire assembly depending upon the requirement.  
 

 
 

Besides that, the filtering of the features can be further narrowed down by selecting one of the 
desired options in the drop-down menu as shown in the figure below. For example, selecting 
CURVE from the option will highlight only the curves in the screen. The default is NO 

SELECTION FILTER. 
 

 
 
General Object Selection: 
 
Clicking on the icon as shown in the figure below will let you select the general object entities 
displayed on the screen.  
 

 



20 
NX7 for Engineering Design                                                                 Missouri University of Science and Technology 

If you want to select any geometric entity, feature, or component, then 
navigate the mouse cursor closer to the entity until it is highlighted with 
a magenta (pink) color and click the left mouse button. 
 
If you want to select an entity that is hidden behind the displayed 
geometry, then place the mouse cursor roughly close to that area on the 
screen such that the cursor ball occupies a portion of the hidden 
geometry projected on the screen. After a couple of seconds, the ball 
cursor turns into a ‘plus’ symbol as shown in the figure.  
 
Click the left mouse button (MB1) to get a ‘Selection Confirmation’ 
dialog box as shown in the following figure below. This QuickPick   
menu consists of the list of entities captured within the ball of the 
cursor. The entities are arranged in ascending order of the ‘degree’ of 
the entity. For example, edges and vertices are assigned lower numbers 
while solid faces are given higher numbers. By moving the cursor on 
the numbers displayed, NX7 will highlight the corresponding entity on 
the screen in a magenta color. For example, in the figure below, the 
face on the top is assigned the number ‘5’. Likewise, the hidden entities will also be allotted with 
a number in the list. You can browse through the numbers and click on the number that 
corresponds to the desired object or feature. 
 

 
 

 
2.3.4 User Preferences 
 
� Choose PREFERENCES on the Menu bar to find the various options available 
 
User Preferences are used to define the display parameters of new objects, names, layouts, and 
views. You can set the layer, color, font, and width of created objects. You can also design 
layouts and views, control the display of object and view names and borders, change the size of 
the selection ball, specify the selection rectangle method, set chaining tolerance and method, and 
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design and activate a grid. Changes that you make 
using the Preferences menu override any counterpart 
customer defaults for the same functions. 
 
User Interface 
 
� Choose PREFERENCES→USER INTERFACE 
to find the options in the dialog box. 
 
The User Interface option customizes how NX works 
and interacts to specifications you set. You can control 
the location, size and visibility status of the main 
window, graphics display, and information window. 
You can set the number of decimal places (precision) 
that the system uses for both input text fields and data 
displayed in the information window. You can also 
specify a full or small dialog for file selection. You can 
also set macro options and enable a confirmation 
dialog for Undo operations. 
 
 

 
 
 

 

• The General tab allows you to set the precision 
level as seen in the Information Window 

• The Layout tab allows you to set the location of the 
Resource Bar 

• The Macro tab allows you to set the pause while 
displaying animation 
 
 
 
Visualization 
 
� Choose PREFERENCES → VISUALIZATION 
to find the options in the dialog box. 
 
This dialog box controls attributes that affect the 
display in the graphics window. Some attributes are 
associated with the part or with particular Views of the 
part. The settings for these attributes are saved in the 
part file. For many of these attributes, when a new part 
or a view is created, the setting is initialized to the 
value specified in the Customer Defaults file. Other 
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attributes are associated with the session and apply to 
all parts in the session. The settings of some of these 
attributes are saved from session to session in the 
registry. For some session attributes, the setting can be 
initialized to the value specified by customer default, 
an environment variable. 
 
� Click on the different tab buttons to find the 

options available under each command. 
 
� Choose PREFERENCES → COLOR PALLETE 

to find the options in the dialog box. 
 

� Click on EDIT BACKGROUND to get another 
pop up Dialog box. You can change your 
background color whatever you want.  

 
The background color refers to the color of the 
background of the graphics window.  NX supports 
graduated backgrounds for all display modes. You can 
select background colors for Shaded or Wireframe 
displays. The background can be Plain or Graduated. 
Valid options for all background colors are 0 to 255. 
 
    
� Click OK when you are done 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

You can also update the background of the graphic window using Preferences.  
 
� Choose PREFERENCES → BACKGROUND 
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Edit Object Display 
 
Object Display option is used to modify the settings such as layer, color, font, width, grid count, 
translucency, and shading status of existing objects. You can select the Edit Object Display icon 
on the Menu Bar as shown below. 
 

 
 
� You can also click PREFERENCES → OBJECT 
 
This will pop up a dialog window OBJECT PREFERENCES or EDIT OBJECT DISPLAY.  
Change and observe the Color and Translucency of the solid object. This is not just limited to 
solid objects. You can also apply this setting to individual entities of the solid. For example, you 
can click on any particular surface of the solid and apply the Display settings.  
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2.3.5 Applications 

Unlike as in the NX5 version, in the NX7 version different APPLICATIONS can be opened 
using the START option tab in the Standard Toolbar. You can select the type of application 
you want to run from the drop down menu. For example, you can select Modeling, Drafting, 
assembly, and so on as shown in the figure. 

The default application that starts when you open a file or start a new file is Modeling. 
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2.4 COORDINATE SYSTEMS 
 

There are different coordinate systems in NX. A three-axis symbol is used to identify the 

coordinate system. 

2.4.1 Absolute Coordinate System 

The Absolute Coordinate System is the coordinate system from which all 
objects are referenced. This is a fixed coordinate system and hence the 
locations and orientations of every object in NX7 modeling space are related 
back to this system. The Absolute Coordinate System (or “Absolute CSYS”) 
also provides a common frame of reference between part files. An absolute 
position at X=1, Y=1, and Z=1 in one part file is the same location in any 
other part file as well.  
 
The View Triad is a visual indicator that represents the orientation of the Absolute coordinate 
system of the model 
 

2.4.2 Work Coordinate System 

The Work Coordinate System (WCS) is what you will use for construction 

when you want to determine orientations and angles of features. The axes of 

the WCS are denoted XC, YC, and ZC. (The “C” stands for “current”). 

 
It is possible to have multiple coordinate systems in a part file, but only one 
of them can be the work coordinate system.  
 
2.4.4 Move the WCS 

Here, you will learn how to translate and rotate the WCS.  

� Choose FORMAT →WCS 
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2.4.4.1 Translate the WCS 
This procedure will move the WCS origin to any point you 
specify, but the orientation (direction of the axes) of the WCS 
will remain the same.  
 
� Choose FORMAT →WCS → ORIGIN 
 
The Point Constructor dialog is displayed in the figure.  
 
You either can specify a point from the drop down menu at 
the top of the dialog box or by entering the X-Y-Z coordinates 
in the XC, YC, and ZC fields. 
 
A majority of the work will be in relation to the Work 

Coordinate System rather than the Absolute Coordinate 

System. The default is the WCS.  
 

 
 
 
The default action button is Inferred Point. The button is highlighted as shown in the figure. The 
name of the active icon appears above the top row of action buttons. This is the point on the 
object, which is closest to the cursor. It can be any of the Snap Points such as the center of circle 
or end-point of a line and so on.  

 
 
 
 
 

� Click CANCEL 
 
2.4.4.2 Rotate the WCS 
 
You can also rotate the WCS around one of its 
axes.  
 
� Choose FORMAT →WCS → ROTATE  
 
The Rotate WCS dialog is shown on the right 
side. The dialog shows six different ways to 
rotate the WCS around an axis. These rotation 
procedures follow the right-hand rule of rotation. 
You can also specify the angle to which the WCS 
be rotated. 
 
� Click CANCEL 
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2.4.4.3 Save the Current Location and Orientation of the WCS 
 

You can save the current location and orientation of the WCS to use as a permanent coordinate 
system.  
 
� Choose FORMAT →WCS → SAVE  
 
2.5 USING LAYERS 
Layers are used to store objects in a file, and work like containers to collect the objects in a 

structured and consistent manner. Unlike simple visual tools like Show and Hide, Layers provide 

a permanent way to organize and manage the visibility and selectability of objects in your file. 

2.5.1 Layer Control 

With NX7, you can control whether objects are 
visible or selectable by using Layers. A Layer is a 
system-defined attribute such as color, font, and 
width that all objects in NX7 must have. There are 
256 usable layers in NX7, one of which is always the 
Work Layer. Any of the 256 layers can be assigned 
to one of four classifications of status: 
 

• Work 

• Selectable 

• Visible Only 

• Invisible 

 

The Work Layer is the layer that objects are created 
ON and is always visible and selectable while it 
remains the Work Layer. Layer 1 is the default Work 

Layer when starting a new part file. When the Work 

Layer is changed to another type of layer, the 
previous Work Layer automatically becomes 
Selectable and can then be assigned a status of 
Visible Only or Invisible. 
 
The number of objects that can be on one layer is not 
limited. You have the freedom to choose whichever 
layer you want to create the object on and the status 
of that layer.  
To assign a status to a layer or layers,  
 
� Choose FORMAT → LAYER SETTINGS 
 
However, it should be noted that the use of company standards in regards to layers would 
be advantageous to maintain a consistency between files. 
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2.5.2 Commands in Layers 
 

We will follow simple steps to practice the commands in Layers. First, we will create two 
objects (Solids) by the method as follows. The details of Solid Modeling will be discussed in the 
next chapter. The solids that we draw here are only for practice in this chapter. 
 
� Choose FILE → NEW 
 
Name the file and choose a folder in which to save it. 
Make sure you selected the units to be inches in the 
drop-down menu. Choose the file type as Model 

 
� Click OK 

 
� Choose INSERT → DESIGN FEATURE → 

CYLINDER OR select the object from the 
Application Toolbar showing the picture of cylinder. 

 

 

 

� Choose AXIS, DIAMETER, HEIGHT under Type 
 

� Click on icon next to Specify Vector 
 

The Vector Constructor dialog will appear. This is 
to specify the direction of the axis of the cylinder. 
The default direction will be in the Z direction.  
 
� Click OK on the pop-up window 

 
� Click on icon next to Specify Point 
 
The Point Constructor window will appear for you 
to determine the location of the cylinder. The 
default location will be the origin (0,0,0) on the 
WCS.  
 
� Click OK   
  
If you would like to change the direction of Axis or 
the Point of origin, click on the boxes outlined in 
red ink as shown in the figure. 
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� Next type 2 inches for the diameter and 4 inches for the height under Properties  
 
� Click OK 
� Click CANCEL on any other window that pops up. 
 
The screen will now look like the following figure. 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
� Right-click on the screen and choose ORIENT VIEW → TRIMETRIC   
 
� If the solid is in wire-frame, right-click on the screen and choose RENDERING STYLE → 

SHADED OR click on the Shaded icon in the toolbar 
 

 
  

 
Now you will be able to see a solid cylinder. 
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Now let us practice some Layer Commands. 
 
� Choose FORMAT → MOVE TO 

LAYER 
 
 You will be asked to select an object.  
 
� Move the cursor on to the cylinder and 

click on it so that it becomes 
highlighted. 

 
� Click OK 

 
You will get the following pop-up window.  
 
� In the Destination Layer or Category space at the top of the window, type 25.  
  
� Choose APPLY, then CANCEL 
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The Cylinder has now gone to the 25th layer. It can no 
longer be seen in Layer 1.  
 
� To see the cylinder, click FORMAT → LAYER 

SETTINGS 
 
You can see that the Layer 25 has the object whereas 
the default Work Layer 1  has no objects. 
 
� Click OK 

 
 The cylinder will again be seen on the screen. Save 
the file as we will be using it later in the tutorial. 
 
 
 
 
 

2.6 IMPORTANT COMMANDS/DIALOGS 
 

In this section, you will learn some important commands and 
dialogs which will be useful during modeling and sketching. 
 
2.6.1 Toolbars 
 

Toolbars contain icons, which serve as shortcuts for many NX7 
functions. The figure on the right shows the main Toolbar items 
normally displayed. However, you can find many more icons for 
different feature commands, based on the module selected and how 
the module is customized. 
 
� Right-Clicking anywhere on the existing toolbars gives a list of 

other Toolbars. You can add any of the toolbars by checking 
them.  

 
The list of toolbars you can see in the default option is Standard, 
View, Selection, Utility, etc. Normally, the default setting should be 
sufficient for most operations but during certain operations, you 
might need additional toolbars.  If you want to add buttons 
pertaining to the commands and toolbars,  
 
� Click on the pull-down arrow on any of the Toolbars and 

choose ADD OR REMOVE BUTTONS.  
 
� Choose CUSTOMIZE. 
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This will pop up a Customize dialog window with all the Toolbars under ‘Toolbar’ Tab and 
commands pertaining to each Toolbar under ‘Commands’ tab. You can check all the toolbars 
that you wish to be displayed.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 

You can customize the settings of your NX7 interface by clicking on the 
Roles tab on the Resource Bar. 
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The Roles tab has different settings of the toolbar menus that are displayed on the NX7 interface.  

• It allows you to customize the toolbars you desire to be displayed in the Interface. 

• Selecting Advanced shows all the Application Toolbars necessary for drafting and 
modeling. 

• You can also select the Application Toolbars to be displayed in the Interface by clicking 
on the Industry Specific settings. This provides a list of industry specific toolbar 
applications as shown below. 
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2.6.2 Transform Functions 
Unlike in NX5, the Transform menu has been modified in NX7. The Transform functions are 

split into two categories. The Move object function is separated from the Transform functions. 

 

� Open the file that you created in section 2.5.2 with the cylinder. 
 

� Click on EDIT → TRANSFORM 
 

 Here, we have to choose an entity such as a solid body or curves or a sketch. You can select a 
single feature or multiple features by clicking on the features. 

 

 
 
� Click on the cylinder so that it gets highlighted 
 
� Click OK 
 
This opens a dialogue box that allows you to perform many functions like scaling, and mirroring 
part of a model as shown in the following figure.  
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You can choose any of these menus. The Scale scales the model. You can create a copy of the 
object using the Mirror through a Line or Mirror through a Plane, create multiple copies of a 
entity such as curve, surface or solid using the Rectangular and Circular Array. 
If you want to Move the an object with respect to fixed entity you can use the Move menu 

 
� Click on EDIT → MOVE OBJECT 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
A dialogue box opens with options as shown in the figure above. Note the Object Handle that 
appears on the object in the form of a coordinate system. You can select the type of motion from 
the MOTION drop-down menu. The default option is Dynamic. With this you can move the 
object in any direction. There are several other ways of moving the object as shown in the figure 
below. 
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• POINT TO POINT – This option allows you to move the center of the cylinder to any 
destination point on the X-Y-Z axis that you want to move. The coordinates are based on the 
WCS.  
 
 

• DISTANCE – This option moves the 
selected object in the X-Y-Z direction by the 
distance that you enter. 
 

� Click on SPECIFY VECTOR 
Select the direction. 

 
� Type 5 in the DISTANCE box.  This will 

translate the cylinder a distance of 5 inches 
along X-Axis 

   
� Click OK 

 
Note that MOVE ORIGINAL is the 
RESULT clicked.  
 

The cylinder will move in the X-direction by a 
distance of 5 inches.  
 
� Click CANCEL  
 
 
 
As you can see, we have moved the cylinder in the X-direction. Similarly, we can also copy the 
cylinder by a specified distance or to a specified location by selecting the COPY ORIGINAL 
option in the RESULT. These are the basic commands that you will need initially.  
 
That completes an introduction of the basics of the NX7 interface and some basic feature 

operations that can be done. In the next chapter, we would learn more about the form features 

and some primitive object types. 
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CHAPTER 3 - FORM FEATURES 

This chapter will discuss the basics of Form Features in NX7: Essentially, we will be discussing 
what a feature is, what the different types of features are, what primitives are and how to model 
features in NX7 using primitives. This will give a head start to the modeling portion of the NX7 
and develop an understanding of the use of Form Features for modeling. In NX7 version, the 
features are categorized in different menus based on the functions and ease of identification.    
 

3.1 OVERVIEW 

In NX7 Features is a class of objects that have a defined parent. Features are associatively 
defined by one or more parents and that retain within the model the order of its creation and 
modification, thus capturing it through the History. Parents can be geometrical objects or 
numerical variables. Features include primitives, surfaces and/or solids and certain wire frame 
objects (such as curves and associative trim and bridge curves). For example, some common 
features include blocks, cylinders, cones, spheres, extruded bodies, and revolved bodies.  

 

Commonly Features can be classified as following 

Body: A class of objects containing solids and sheets. 

Solid Body: A collection of faces and edges that enclose a volume. 

Sheet Body: A collection of one or more faces that do not enclose a volume. 

Face: A region on the outside of a body enclosed by edges. 
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3.2 TYPES OF FEATURES  
 

There are six types of Form features: Reference features, 
Swept features, Remove features, User-defined features, 
Extract features and Primitives. Just like the NX5 version, the 
NX7 version stores all the Form Features under the 
INSERT menu option. The form features are also available 
in the Form Features Toolbar.  
 
� Click INSERT on the Menu bar  
 

As you can see, the marked menus in the figure on the right 

side contain the commands of Form Features.  

The Form Feature icons are grouped in the Form Features 

Toolbar as shown below. You can choose the icons that you 

use frequently.  

� Click on the drop down arrow in Form Feature Toolbar 
� Choose ADD OR REMOVE BUTTONS 
� Choose FORM FEATURE 
 

 

Reference Features  

These let you create reference planes or reference axes. These references can assist you in 
creating features on cylinders, cones, spheres and revolved solid bodies.  
 
� Click on INSERT → DATUM/POINT to view the different Reference Feature options: 

Datum Plane, Datum Axis, Datum CSYS, and Point 
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Swept Features  

These let you create bodies by extruding or revolving sketch geometry. Swept Features include: 

• Extruded Body 

• Revolved Body 

• Sweep along Guide 

• Tube 

• Styled Sweep 
 
To select a swept feature you can do the following: 
 
� Click on INSERT → DESIGN FEATURE for Extrude and Revolve  
or 
�  Click on INSERT → SWEEP for the rest of the options 
 
Remove Features  

Remove Features let you create bodies by 
removing solid part from other parts.  
 
� Click on INSERT → DESIGN FEATURE  
 
Remove Features include, 

• Hole 

• Boss 

• Pocket 

• Pad 

• Slot 

• Groove 
 

You can also select the features by clicking on 

the icons  
 
User-Defined features  

These allow you to create your own form features to automate commonly used design elements. 
You can use user-defined features to extend the range and power of the built-in form features. 
 
� Click on INSERT → DESIGN FEATURE → USER DEFINED 
 
Extract Features 

These features let you create bodies by extracting curves, faces and regions. These features are 
widely spaced under Associative Copy and Offset/Scale menus. Extract Features include: 

• Extract 

• Sheet from curves 

• Bounded plane 
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• Thicken Sheet 

• Sheet to Solid Assistant 
 
� Click on INSERT → ASSOCIATIVE COPY → EXTRACT for Extract options 
 
 
� Click on INSERT → OFFSET/SCALE for Thicken Sheet and Sheets to Solid Assistant 
 
 
 
 
 
 
 
 
� Click on INSERT → SURFACE for Bounded Plane and Sheet from curves 
 
 
 
 
 
 
 
 
Primitives  

They let you create solid bodies in the 
form of generic building shapes. 
Primitives include, 
 

• Block 

• Cylinder 

• Cone 

• Sphere 
 

 

Primitives are the primary entities. Hence we will begin with a short description of primitives 

and then proceed to modeling various objects. 

3.3 PRIMITIVES 
 

Primitive features are base features from which many other features can be created. The basic 
primitives are blocks, cylinders, cones and spheres. Primitives are non-associative which means 
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they are not associated to the geometry used to create them. The parameters of these primitive 
objects can be changed. 
Now let us start modeling of some basic objects. 
 
3.3.1 Model a Block 
 

� Create a new file and name it as 
Arborpress_plate.prt 

 
Now let us model a plate.   
 
� Choose INSERT → DESIGN FEATURE → 

BLOCK or click on the Block icon in the Form 

Feature Toolbar 
 

The Block window appears. There are three main 
things to define a block. They include the Type, 
Origin and the Dimensions of the block. To access 
the Types scroll the drop-down menu under Type. 

There are three ways to create a block primitive. 
 

• Origin, Edge Lengths  

• Height, Two Points 

• Two Diagonal Points 
 
� Make sure the Origin, Edge Lengths method is 

selected 
 
Now, we will choose the origin using the Point 

Constructor.  
 
� Click on the POINT CONSTRUCTOR icon 

under the Origin 
or 

� Click on the POINT CONSTRUCTOR  icon in the Utility Toolbar as shown in the 
following figure.  

 
 

 
 
The Point Constructor box will open. The XC, YC, ZC points should have a default value of 0. 
 
� Click OK 
The Block window will reappear.  
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� Type the following dimensions in the 
window. 
Length (XC) = 65 inches 
Width (YC) = 85 inches 
Height (ZC) = 20 inches 

 
� Click  OK 
 
� If you do not see anything on the screen, right-click and select FIT. You can also press 

<Ctrl> + F 
� Right-click on the screen and click on ORIENT VIEW → TRIMETRIC 
 

 

You should be able to see the complete plate solid model.  Save and close the part file. 
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3.3.2 Model a Shaft 
 

After modeling a basic block, we will now model a shaft 
having two cylinders and one cone joined together. 
 
� Create a new file and save it as Impeller_shaft.prt 

 

� Choose  INSERT → DESIGN FEATURE → 
CYLINDER  

 
Similar to the Block there are three things that need to be 
defined to create a cylinder, Type, Axis & Origin, 

Dimensions. 
 
A Cylinder can be defined by two types which can be 
obtained by scrolling the drop-down menu under Type 

• Axis, Diameter, Height  

• Arc, Height 
 
� Select AXIS, DIAMETER, HEIGHT 
 
� Click on the Vector Constructor icon next to Specify 

Vector as shown on the second figure on right. 
 
� Click on the ZC Axis icon.  

 
� Leave the other options as default and click OK 
 

� Click on the Point Constructor icon next to Specify 
Point to set the origin of the cylinder 

 
� Set all the XC, YC, and ZC coordinates to be 0 
 

You can see that the selected point is the origin of WCS 

� In the next dialog box of the window, type in the 
following values as shown in figure 
Diameter = 4 inches 
Height = 18 inches 

 
 
 
 
� Click OK 
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� Click CANCEL on any other windows that appear 
  
� Right-click on the screen, choose ORIENT VIEW → ISOMETRIC  
 
You can change the color of the solid body and the background as mentioned in the Chapter 
2.3.4.  The cylinder will look as shown below.  
 

 

 

 

 

 

 

 

Now we will create a cone at one end of the cylinder.  
 
� Choose  INSERT → DESIGN FEATURE → CONE 
 
Similar to Block and Cylinder there are various ways to 
create a cone which can be seen by scrolling the drop-
down menu in the Type box. 
 

• Diameters, Height 

• Diameters, Half Angle 

• Base Diameter, Height, Half Angle 

• Top Diameter, Height, Half Angle 

• Two Coaxial Arcs 
 

� Select DIAMETERS, HEIGHT 
 
� Click on the Vector Constructor icon next to Specify 

Vector. 
  

� Choose the ZC-Axis icon so the vector is pointing in 
the positive Z direction  

 
� Click OK 

 
� Click on the Point Constructor icon next to Specify Point to set the origin of the cylinder. 
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The Point Constructor window will appear next. 
  
� Choose the Arc/Ellipse/Sphere Center icon on the 

dialog box and click on the top circular edge of the 
cylinder  

OR 
� For the Base Point coordinates, type in the 

following values: XC = 0     YC = 0     ZC = 18 
 

� Click OK 
 
� In the cone window, type in the following values: 

Base diameter = 4 inches 
Top Diameter = 6 inches 
Height = 10 inches 
 

� Click OK 
 
� On the Boolean Operation window, choose 

UNITE 
 
Now the cone will appear on top of the cylinder. 
 
� Click CANCEL on any other windows  
 
� Press <Ctrl> + F OR right-click and select FIT  
 
The shaft is as shown on right. 
 
Now we will create one more cylinder on top of the cone. 
 
� Repeat the same procedure as before to create another Cylinder. 

The vector should be pointing in the positive ZC-direction. On the 
Point Constructor window, again click on the Center icon and 
construct it at the center point of the base of the cone. The 
cylinder should have a diameter of 6 inches and a height of 20 
inches.  

 
The complete shaft will look as shown below.  Remember to save the model. 
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3.4 REFERENCE FEATUR
 

3.4.1 Datum Plane 
 

Datum Planes are reference features that can be used as
Datum planes assist in creating features on cylinders, cones, spheres, and revolved solid bodies
which do not have a planar surface and
to the faces of the target solid.
Features. For starters, we will create a 
  

 
� Open the model Arborpress_plate.prt
 
� Choose INSERT → DATUM/POINT
 
The Datum Plane dialog can also be opened by clicking the icon as shown in the figure below 
from the Form Feature Toolbar
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3.4 REFERENCE FEATURES 

reference features that can be used as a base feature in building a model. 
assist in creating features on cylinders, cones, spheres, and revolved solid bodies

which do not have a planar surface and also aid in creating features at angles other than normal 
to the faces of the target solid. We will follow some simple steps to practice 

we will create a Datum Plane that is offset from a face. 

 

Arborpress_plate.prt  

DATUM/POINT → DATUM PLANE  

can also be opened by clicking the icon as shown in the figure below 
oolbar. 

 

Missouri University of Science and Technology 

in building a model. 
assist in creating features on cylinders, cones, spheres, and revolved solid bodies 

also aid in creating features at angles other than normal 
imple steps to practice Reference 

can also be opened by clicking the icon as shown in the figure below 
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The Datum Plane window, shown on the right side, 

allows you to choose the method of selection. 

However, NX7 is smart enough to judge the method 

depending on the entity you select, if you keep in 

inferred option, which is also the Default option. 

� Click on the top surface of the block so that it 
becomes highlighted 
 

The vector displays the positive offset direction that 
the datum plane will be created in. If you had selected 
the bottom face, the vector would have pointed 
downward, away from the solid.  
 
� Insert the Offset Distance value as 15 inches in 

the dialog box and click APPLY on the Datum 
Plane Window 

 

The offset Datum Plane will look as below. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
� Click CANCEL once you are done 
 
� If you don’t see the complete model and plane, right-click and select FIT 
 
3.4.2 Datum Axis 
 

In this part, you are going to create a Datum Axis. A Datum Axis is a reference feature that can 
be used to create datum planes, revolved features, extruded bodies, etc. 
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Datum Axes can be created either relative to another object or as a fixed 
axis (i.e., not referencing, and not constrained by
 
� Choose INSERT → DATUM/POINT
 
The Datum Axis dialog can also be opened by clicking the icon as shown in the figure on the 
right from the Form Feature toolbar
 

The next window allows you to choose the method of selecting 

the axis. However, NX7 can judge which method to use 

depending on the entity you select. 

 

There are various ways to make a 
Point and Direction, Two Points, 
 
� Select the Two Points icon at the top right of the 

� Select the two points on the block as shown in the figure 
on right 

 
� Click OK 
 

 
The Datum Axis will be a diagonal as shown below.
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can be created either relative to another object or as a fixed 
rencing, and not constrained by other geometric objects). 

DATUM/POINT → DATUM AXIS 

can also be opened by clicking the icon as shown in the figure on the 
Form Feature toolbar. 

The next window allows you to choose the method of selecting 

the axis. However, NX7 can judge which method to use 

.  

There are various ways to make a datum axis. They include 
, Two Planes, etc.   

icon at the top right of the Datum Axis window  
 
 
 
 
 
 
 

Select the two points on the block as shown in the figure 

will be a diagonal as shown below. 

Missouri University of Science and Technology 

can also be opened by clicking the icon as shown in the figure on the 
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3.5 SWEPT FEATURES 
 

3.5.1 Extruded Body 

The Extruded Body option lets you create a solid or sheet body by sweeping generator geometry 
(curves, solid faces, solid edges, sheet body) in a 

In this part, we will extrude a rectangle
rectangular block as follows.  
 
� Create a new part file and save it as 

Arborpress_rack.prt 
 
� Right-click, then choose 

VIEW → ISOMETRIC  
 
To learn the extrude command, we will create 
a 2D rectangle first and then extrude this 
rectangle to form a solid. 
 
� Choose INSERT → CURVE 

RECTANGLE  
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option lets you create a solid or sheet body by sweeping generator geometry 
(curves, solid faces, solid edges, sheet body) in a linear direction for a specified distance

extrude a rectangle into a 

Create a new part file and save it as 

click, then choose ORIENT 

de command, we will create 
a 2D rectangle first and then extrude this 

 CURVE → 

Missouri University of Science and Technology 

option lets you create a solid or sheet body by sweeping generator geometry 
linear direction for a specified distance.  
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You can also choose the Rectangle icon in the Sketch Toolbar as shown below.  

 

 

The Point Constructor window will 

open as shown on the right. Note the 

Cue Line instructions. The Cue Line 

provides the step that needs to be 

taken next. You need to define the 

corner points for the Rectangle.  

For Corner Point 1,  
� Type in the coordinates XC = 0, 

YC = 0, ZC = 0 and click OK 
 

Another Point Constructor window 
will pop up, allowing you to define 
the 2nd Corner Point 

 
� Type in the coordinates XC = 

240, YC = 25, ZC = 0 and click 
OK and then click Apply 

 

� Right-click on the screen and choose FIT  
 

You should see the rectangle as seen below. 

 

 
Now we will extrude the rectangle to form a solid.   

� Choose INSERT → DESIGN FEATURE → EXTRUDE 
OR 
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� Click on the Extrude icon on the left of the Form Feature Toolbar as shown in the figure 
below 

 
 

The Extrude dialog box will pop up.  

� Click on all four lines of the rectangle. You can find the preview on the Graphic screen as 
you proceed with the selection of the lines.  
 

� Choose the default positive ZC-direction as the Direction 
 

� In the Limits window, type in the following values: 
Start = 0   

  
End = 20 
 

� Click OK 
 

 
 
 
 
 
 
 
 
 
 
 
 
The extruded body will appear as shown below. Save your work and close the file.  
 

 

Similar to the Extrude function, we can also perform functions such as Revolve, Tube, etc. 
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3.6 REMOVE FEATURES
 

Some features allow you to remove a portion of the existing object to create an object with 
additional features that are part of the design. These are illustrated below. 
 
Hole: 

This option lets you create simple, counter
 

Boss 

This option lets you create a simple cylindrical protrusion on a planar face or datum plane
 
Pocket 

This creates a cavity in an existing body. It can be cylindrical or rectangular.  
 
Pad 

Use the Pad option to create a rectangle on an existing solid body.
 

Slot 

This option lets you create a passage through or into a solid body in the shape of a straight slot. 
An automatic subtract is performed on the current target solid. It can be rectangular, T
Slot, Ball end or Dovetail. 
 
Groove 

This option lets you create a groove in a solid body, as if a form tool moved inward (from an 
external placement face) or outward (from an internal placement face) on a rotating part, as with 
a turning operation. 
 
Thread 
This option allows you to create symbolic thread or a detailed thread on a cylindrical face of a 
solid body. 
 
We will now learn to create holes.
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S 

Some features allow you to remove a portion of the existing object to create an object with 
additional features that are part of the design. These are illustrated below.  

This option lets you create simple, counter-bored and countersunk holes in solid bodies.

This option lets you create a simple cylindrical protrusion on a planar face or datum plane

This creates a cavity in an existing body. It can be cylindrical or rectangular.   

create a rectangle on an existing solid body. 

This option lets you create a passage through or into a solid body in the shape of a straight slot. 
An automatic subtract is performed on the current target solid. It can be rectangular, T

lets you create a groove in a solid body, as if a form tool moved inward (from an 
external placement face) or outward (from an internal placement face) on a rotating part, as with 

option allows you to create symbolic thread or a detailed thread on a cylindrical face of a 

We will now learn to create holes. 

Missouri University of Science and Technology 

Some features allow you to remove a portion of the existing object to create an object with 

nd countersunk holes in solid bodies. 

 

This option lets you create a simple cylindrical protrusion on a planar face or datum plane. 

This option lets you create a passage through or into a solid body in the shape of a straight slot. 
An automatic subtract is performed on the current target solid. It can be rectangular, T-slot, U-

lets you create a groove in a solid body, as if a form tool moved inward (from an 
external placement face) or outward (from an internal placement face) on a rotating part, as with 

option allows you to create symbolic thread or a detailed thread on a cylindrical face of a 
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� Open the file Arborpress_plate.prt 
� Choose INSERT → DESIGN FEATURES → HOLE or click on the icon in the Form 

Feature Toolbar as shown  
 

 
 
The Hole window will open. There are various 
selections that need to be done prior to making the 
holes. First you need to select the Type of the hole.  
 
� Select the default General Hole 

 
Next you need to define the points at which you 
need to make the holes. 
 
� Click on the Sketch icon in the Position dialog 

box and choose the top face of the plate as the 
Type of Sketch 

 

 
 
� Click OK 
 
This will take you the Sketch Plane. 

 
 
 
 
� Click on the POINT CONSTRUCTOR icon 
and specify all the points as given in the Table 
below. 
 
You can specify either one point or all the points at 
the same time. 
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X Y Z 

11.25 10.00 0.00 

32.50 23.50 0.00 

53.75 10.00 0.00 

11.25 75.00 0.00 

32.50 61.50 0.00 

53.75 75.00 0.00 

 
� Click OK after you enter the coordinates of each 

point. 
 
Note the dimensions of the hole appear 
automatically. You can hide all the dimensions by 
selecting, and right clicking and selecting Hide 
 

� Click CLOSE once you have entered all the 
points. 

 
� Click on FINISH SKETCH in the top left corner 

of the window 
 

 
 
This will take you out of the Sketch mode and bring back to the original Hole window on the 
graphics screen. 
 
� In the Form dialog choose the default option of Simple Hole. 
 
� Enter the following values in the Dimensions window 

Diameter = 8 inches   
Depth = 25 inches   
Tip Angle = 118 degrees 
 

� Choose Subtract in the Boolean dialog box 
 

� Click OK 
 
The final plate will be as shown below. 
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We have now completed the basic form features. The user-defined form features are advanced 
options in which new form features are added into the library.  
 

3.7 EXERCISE - MODEL A WASHER 
 

As an exercise, model a washer as shown in the 

figure.  

 

 

The washer has the following dimensions. 

Outer diameter = 0.73 inches 

Inner diameter = 0.281 inches 

The thickness of the washer can vary within 

realistic limits. For practice take the value to be 

0.05 inches. 
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CHAPTER 4 – FEATURE OPERATIONS 
 

Feature operations are the continuation of Form Features. In this chapter, you will learn some of 
the functions that can be applied to the faces and edges of a solid body or feature you have 
created. These include taper, edge blend, face blend, chamfer, trim, etc. After explaining the 
feature operations, the chapter will walk you through some examples. As mentioned in the 
beginning of Chapter 3, Feature Operations are categorized into different options under the 
INSERT menu. Therefore, you will not find a single menu group as ‘Feature Operations’ under 
the INSERT menu, however all the Feature Operations are grouped in the Form Features 

Toolbar. 
 
 

4.1 OVERVIEW  
 

Feature operations are performed on the basic Form Features to smooth corners, create tapers, 
and unite or subtract certain solids from other solids. Some of the feature operations are shown 
below. 

 

Let us see the different types of feature operation commands in NX7 and the function of each 
command. 
 

4.2 TYPES OF FEATURE OPERATIONS 
 

The Features Operations used in NX7 include Edge blend, Face blend, Soft blend, Chamfer, 
Hollow, Instance, Sew, and Patch. Let us see some of the important operations in details. Unlike 
the NX5 where Feature Operations were grouped in a Toolbar as a part of the Form Feature 
Toolbar, in NX7 the entire toolbar has been combined into one. In addition, changes have been 
made to the way a few operations are performed. 
 
 The Feature Operations can be categorized into five main components found under the 
INSERT menu. They are as Associative Copy, Combine, Trim, Offset/Scale and Detail 

Feature. In this chapter we will be looking at some of these operations only. 
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Edge Blend 
 
An Edge Blend is a radius blend that is tangent to the 
blended faces. This feature modifies a solid body by 
rounding selected edges. This command can be found 
under Insert → Detail Feature → Edge Blend  
In this case you need to select the edges to be blended 
and define the Radius of the blend. 
Similar to Edge Blend you can also do a Face Blend.   
 

   
 

Chamfer 
 
The Chamfer function operates very similarly to the 
blend function by adding or subtracting material 
relative to whether the edge is an outside chamfer or 
an inside chamfer. This command can also be found 
under the Insert → Detail Feature → Chamfer 
menu.  
 

 
You can preview the result of chamfering and if you are not happy with the result you can undo 

the operation.  

Thread 
 
Threads can only be created on cylindrical faces. The Thread function lets you create symbolic 

or detailed threads (on solid bodies) that are right or left hand, external or internal, parametric, 

and associative threads on cylindrical faces such as holes, bosses, or cylinders. It also lets you 

select the method of creating the threads such as cut, rolled, milled or ground. You can create 
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different types of threads such as metric, unified, acme and so on. To use this command, go to 

Insert → Design Feature → Thread 

 

   

 

Trim Body 
 
A solid body can be trimmed by a sheet body or a 
datum plane. You can use the Trim Body function to 
trim a solid body with a sheet body and at the same 
time retain parameters and associativity. To use this 
command, go to Insert → Trim → Trim Body 
 
 
Split Body 

 
A solid body can be split into two just like trimming it. 
It can be done by a plane or a sheet body. 
Insert → Trim → Split Body 
 

 
 
 
 
 
 

 

  

 

Instance 
 
A Design Feature or a Detail Feature can be made into dependent copies in the form of an 
array. It can be Rectangular or Circular array or just a Mirror. This particularly helpful feature 
saves plenty of time and modeling when you have similar features. For example threads of gear 
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or holes on a mounting plate, etc. This command can be found by going to Insert → Associative 
Copy → Instance Feature.  
 

 
  

  
 
 
 
 
 
 

 
Boolean Operations 
 
Boolean operations are: 

• Unite  

• Subtract   

• Intersect  
 

These options can be used when two or more solid bodies share the same model space in the part 
file. To use this command, go to Insert → Combine Bodies.  
Consider two solids given. The block and the cylinder are next to each other as shown below. 
 

   
 
 
 
 
 
 
 
 

  Unite: 
The unite command adds the Tool body with the Target body. For the above example, the output 
will be as follows if Unite option is used. 
 

   

 
 

 

 



60 
NX7 for Engineering Design                                                                 Missouri University of Science and Technology 

  Subtract: 
When using the subtract option, the Tool body is subtracted from the Target body. The following 
would be the output if the rectangle is used as the Target and the cylinder as the Tool.  
 

  

  Intersect: 

This command leaves the volume that is common to both the Target body and the Tool body. 

The output is shown below.  

  

4.3 FEATURE OPERATIONS ON MODELS 
 

In the previous chapter, we dealt with some of the Form Features. In this chapter, we will see 
how the primitives and basic form features can be converted into complex models by using 
Feature Operations. The following are a set of examples that will guide 
you in creation of some simple models. 
 
4.3.1 Model a Hexagonal Screw 
 

� Create a new file and save it as Impeller_hexa-bolt.prt 
 

� Choose INSERT → DESIGN FEATURE →  CYLINDER  
 
� The cylinder should be pointing in the positive ZC-direction with the 

center set at the Origin and with the following dimensions: 
Diameter = 0.25 inches     
Height = 1.5 inches 



61 
NX7 for Engineering Design                                                                 Missouri University of Science and Technology 

Now create a small step cylinder on top of the 

existing cylinder. 

 
� The dimensions of this cylinder are, 
 Diameter = 0.387 inches 
 Height = 0.0156 inches 
 
� Click on the top face of the existing 

cylinder as shown in the following figure 
 
� On the Point Constructor window, 

choose the Arc/Ellipse/Sphere Center icon 
from the drop-down Type menu 
 

� Click OK to get out of Point Constructor window.  
 

� Under the Boolean drop-down menu, 
choose UNITE 

 
The two cylinders should look like the figure 
shown below. Save the model.  
 
Next, we will create a hexagon for the head of 
the bolt. 
 

 

 

 

 

 

 

 

� Choose INSERT → CURVE → POLYGON  
 

� On the Polygon window, type 6 for the 
number of sides 

  
� Click OK 
 

There are three ways to draw the polygon. 



62 
NX7 for Engineering Design                                                                 Missouri University of Science and Technology 

• Inscribed Radius 

• Side of Polygon 

• Circumscribed Radius 
 
� Choose SIDE OF POLYGON 

 
� On the next window, enter the following 

dimensions. 
Side = 0.246 inches   
Orientation Angle = 0.00 degree 

 
� Click OK 

 
� On the Point Constructor window, again choose 

Arc/Ellipse/Sphere Center icon 
 

� Click on the top face of the last cylinder drawn (small cylinder) 
 

 
 
 
 
 
 
 
 
 
 
 
� Click CANCEL 
 
The polygon will be seen as shown below. If the model is not in wireframe, click on the 

Wireframe icon in the View Toolbar  
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Now we will extrude this polygon. 
 
� Choose INSERT → DESIGN FEATURE → EXTRUDE 
 
� Click on all six lines of the hexagon to choose the surface that is required to be extruded 
 
� Enter the End Distance as 0.1876 inches  
 
The model looks like the following after extrusion 
 

 

 

 

 

 

 

 

� On top of the cylinder that has a diameter of 0.387 inches, insert another cylinder with the 
following dimensions. 
Diameter = 0.387 inches   
Height = 0.1875 inches 

Remember to select the Arc/Ellipse/Sphere Center icon in the drop-down menu of Type in the 

Point Constructor window and select the top face of the cylinder with diameter of 0.387. 
 
You will only be able to see this cylinder when the model is in wireframe since the cylinder is 
inside the hexagon head. The model will look like the following. 
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We will now use the feature operation Intersect. 
 
� Choose INSERT → DESIGN FEATURE → SPHERE  

 
� Choose DIAMETER, CENTER 

 
� On the Point Constructor window, choose the Center icon  
 
� Select the bottom of the last cylinder drawn, which is inside the hexagon head and has a 

diameter of 0.387 inches and a height of  0.1875 inches as shown below 
 

 

 

 

 

 

 

 

 

 

 

� Click OK 
 
This will give take you the next 
Dialog box which will ask you to 
choose the Boolean operation to be 
performed. 
 
� Choose INTERSECT 
 
It will ask you to select the target 
solid 
 
� Choose the hexagonal head as 

shown on right 
 
� Click OK 
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� Click CANCEL 
 
This will give you the hexagonal bolt as shown below. 
 

 
* NOTE: Take care when creating the different features (three cylinders, extrusion of 
hexagon), the Boolean dialog box has the value “NONE” 
 
Now we will add threading to the hexagonal bolt. 
 
� Choose INSERT → DESIGN 

FEATURE  → THREAD 
 
Here you will see the threading 
dialog box as shown below. 
 

There are two main options in 
Threading:  
1) Symbolic and 2) Detailed. 
 
� Click on the DETAILED radio 

button 
 
� Keep the thread hand to be 

RIGHT HAND 
 

� Click on the bolt shaft, the long cylinder below the hexagon head 
 

Once the shaft is selected, all the values will be displayed in the Thread dialog box. Keep all 
these default values. 
 
� Click OK 

 
The hexagon bolt should now look like the following. Save the model.  
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4.3.2 Model an L-Bar 
 

Here we will make use of some Feature Operations such as Edge Blend, Chamfer, and 

Subtract. 

� Create a new file and save it as Arborpress_L-bar 
 

� Choose INSERT → DESIGN FEATURE → BLOCK  
 

� Create a block with the following dimensions. 
Length = 65 inches 
Width = 65 inches 
Height = 285 inches 

 
� Create the block at the origin 
 

� Create a second block also placed at the origin with the following 
dimensions. 
Length = 182 inches 
Width = 65 inches 
Height = 85 inches 

 
We have to move the second block to the top of the first block.  
 
� Click EDIT → MOVE OBJECT 

 
� Select the second block (green) that you inserted which is longer 

in the XC-direction 
 
� Click OK 
 
� Choose the Motion as DISTANCE 
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� Select the positive ZC in the Specify Vector dialog 
 

� Enter 200 as the Distance value 
 

Make sure that Move Original radio button is checked. 
 

� Click OK 
 
� Click MOVE and then CANCEL on the next 

window so that the operation is not repeated 
 
After transformation, it will look like the following. 
 

 
 
Now we will create a hole. There are many 
ways to create a hole. We will do so by first 
creating a cylinder and then using the 
Subtract function. 
 
� Choose INSERT → DESIGN 

FEATURE → CYLINDER 
 
� On the Vector Constructor window, 

select the YC Axis icon 
 
� In the Point Constructor dialog box, 

enter the following values 
 

Axes XC YC ZC 

Dimension 130 -5 242 

 
� The cylinder should have the following 

dimensions. 
Diameter = 35 inches 
Height = 100 inches 
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� Under the Boolean drop-down window, choose SUBTRACT 
 

� Select the horizontal block at the top as shown in the figure on 
the right side 

 

The hole should look like the one in the figure. Save your model.  
 

Now we will create another cylinder and subtract it from the upper 
block. 
 
� The cylinder should be pointing in the positive Y-direction set at 

the following point: XC = 130; YC = 22.5 
and ZC = 242 

 
� The cylinder should have the following 

dimensions. 
Diameter = 66 inches 
Height = 20 inches 

 

� Subtract this cylinder from the same block as 
before using the Boolean drop-down menu  

 
The wireframe model will be seen as shown 
below.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Now we will create a block. 
 
� Choose INSERT → DESIGN FEATURE → BLOCK  
 
� Create a block with the following dimensions. 

Length = 25 inches 
Width = 20 inches 
Height = 150 inches 
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� Click on the Point Constructor icon in the Block window and enter the following values  
 

Axes XC YC ZC 

Values 157 22.5 180 

 
The model will look like the following figure. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Now we will subtract this block from the 
block with the hole. 
 
� Choose INSERT → COMBINE 

BODIES → SUBTRACT 
 

� Click on the block with the two holes 
(green) as the Target 
 

� Select the newly created block (brown) as 
Tool 
 

� Click OK 
 
The model will be seen as shown below. 
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Now we will use the Blend function in the feature operations. In order to do so, we must first 
unite the two blocks. 
 
� Choose INSERT → COMBINE BODIES → UNITE 

 

� Click on the two blocks and click OK 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The two blocks are now combined into one solid model. 
 

� Choose INSERT → DETAIL FEATURE →→→→ EDGE BLEND 
 

� Change the Radius to 60  
 

� Select the edge that the arrow is pointing to in the figure 
 

 
 

 

 

 

 

 

 

 

 

� Click OK  
 

The blend will look as shown below. 
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� Repeat the same procedure to Blend the inner edge of the blocks. This time, the Radius 
should be changed to 30 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The blended figure is shown below. Remember to save the model. 
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We will now make four holes in the model. You can create these holes by using the Hole option 
as illustrated in Chapter 3; however, to practice using Feature Operations, we will subtract 
cylinders from the block.  
 
� Insert four cylinders individually. They 

should be pointing in the positive XC-
direction and have the following 
dimensions. 
Diameter = 8 inches    
Height = 20 inches 

 

They should be constructed in the XC-

direction at the following point coordinates. 

 

� SUBTRACT these cylinders from the 
block in the Boolean dialog box 

 
The block with holes looks like as shown in figure below 

 

 

The last operation on this model is to create a block and subtract it from the top block. 
 
� Create a Block with the following dimensions. 

Length = 60 inches 
Width = 20 inches 
Height = 66 inches  

 1 2 3 4 

X 162 162 162 162 

Y 11.25 11.25 53.75 53.75 

Z 210 275 210 275 
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� Enter the following values in the Point Constructor dialog by clicking the 
icon  

 

Axes XC YC ZC 

Dimension 130 22.5 209.5 

 

� After creating the block, subtract this 
block from the block at the top by first 
selecting the original block and then 
clicking on the newly created block 

 
 
 
 
 
 
 
 
 
 
 
 
The final figure will look like this. Save 
and close the file.  
 

 

4.3.3 Model a Hexagonal Nut 

 

� Create a new file and save it as Impeller_hexa-nut.prt 
 
� Choose INSERT → CURVE → POLYGON  
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� Create a hexagon with the option SIDE OF POLYGON and each side measuring 0.28685 
inches and constructed at the Origin.  

 
� Choose INSERT → DESIGN FEATURE → EXTRUDE 
 
� Click on all six lines of the hexagon to choose the surface that is required to be extruded 
 
� Enter the End Distance as 0.125 inches  
 
The figure of the model is shown below.  
 

 

 
� Choose INSERT → DESIGN FEATURE → SPHERE 

  

� Choose CENTER, DIAMETER  
 

� Enter the diameter value 0.57 inches 
 

� Enter the center point location in the Point Constructor window as follows 
 
 

 
 

� In the Boolean operations dialog box select INTERSECT 
 

The model will look like the following. 

 

Axes XC YC ZC 

Dimension 0.0 0.0 0.125 
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We will now use a Mirror command. 
 

� Choose EDIT → TRANSFORM  
 

� Select the model and click OK 
 

� Click MIRROR THROUGH A PLANE  
 
� Click on the flat side of the model as shown. Be careful 

not to select any edges 

 
� Click on OK 
 
� Click on COPY 
 
� Click CANCEL 

 
You will get the following model.  

 

 

 

 

 

 

 

� Choose INSERT → COMBINE BODIES → UNITE  
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� Select the two halves and Unite them 
 
 

 
 
 
 
 
 
 
 
 
 

� Insert a Cylinder with the vector pointing in the ZC-Direction and with the following 
dimensions. 
Diameter = 0.25 inches 
Height = 1 inch 
 

� Put the cylinder on the Origin and Subtract this cylinder from the hexagonal nut 
 
 
 
 
 
 
 
 
 
 
 

Now, we will chamfer the inside edges of the nut. 
 
� Choose INSERT → DETAIL FEATURE → CHAMFER 
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� Select the two inner edges as shown and click OK 
 

� Enter the Chamfer Offset Diameter as 0.0436 inches and click OK  
 
You will see the chamfer on the nut. Save the model. 
 

 

4.3.4 Model a Rack with Instances 
 

In this part, we will practice to create instances of a given object.  
 
� Open the file Arborpress_rack.prt 
 
� Choose INSERT → DESIGN FEATURE → POCKET 
 
� Choose RECTANGULAR in the pop up window 

 
� Click on the top surface of the rack as shown in the figure for the placement surface. 
 
Keep an eye on the Cue Line. It gives the next instruction. 
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� Click on the edge as shown in the figure for the Horizontal Reference 
 

  

 

 

 

 

 

 

This will pop up the parameters window.  

� Enter the values of parameters as shown in the figure and choose OK 
 

 

� Choose Wireframe option in the Display mode for more clarity  
 

� When the Positioning window pops up, choose the PERPENDICULAR option  
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� Click on the edge on the solid and then click on the blue dotted line as shown below  
 

 

 
� Enter the expression value as 37.8 and Choose OK 
 

 

 

� Once again pick the PERPENDICULAR option and then choose the other set of the edges 
along the Y-Axis, as shown in the figure below.  

 

� Enter the expression value as 10 and choose OK twice. Choose CANCEL.  
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The model will now look as follows.  

 

 

Let us create the instances of the slot as the teeth of the Rack to be meshed with pinion.  

 
� Choose INSERT → ASSOCIATIVE COPY→ INSTANCE FEATURE 
 
� Choose RECTANGULAR ARRAY from the selection tabs 
 
� Choose RECTANGULAR POCKET 

from the Instance Dialog box as shown 
in the figure below 

 
� Choose OK 
 

� Enter the values in the parameter 
window as shown in the figure. This 
creates 19 copies including the original at the offset 
distance of 9.4 inches 

 
� Choose OK 
 

� Click YES 
 

� Click CANCEL 
 

The model of the Rack will look as the one shown in the 

figure.  
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We will create a hole with diameter 10 inches and depth 20 inches at the center of the 

rectangular cross section.  

To determine the center of the cross-section of the rectangular rack, we make use of the Snap 

Points 

 

� Choose INSERT → DESIGN FEATURE → CYLINDER 
 

� Choose –XC-Direction to in the Specify Vector dialog box 
 

� Click on the POINT CONSTRUCTOR  

 
� In the Points dialog box select 

Between Two Points option and 
select the points as shown in the 
figure on the right. 
 

� Click OK 
 

� Enter the following values in the 
Dimension dialog box 

Diameter – 10 inches 
Height – 20 inches  
 

� Choose Subtract in the Boolean 
dialog box. 
 

� The final model is shown below.  
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4.4 EXERCISE - MODEL A CIRCULAR BASE 
 

As an exercise, model a circle base as shown below using the following dimensions: 

 

Outer diameter = 120 inches 

Distance of 3 small slots = 17 inches 

Distance of the large slot = 30 inches 

Diameter of the central rod = 4 inches and length = 30 inches 

Length of slots may vary. 

 

 

 

Top and Front view dimensions are shown in the figure below. 
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The NX7 Drafting application lets you create drawings, views, geometry, dimensions, and 
drafting annotations necessary for the completion as well as understanding of a industrial 
drawing. The goal of this chapter is to give the designer/draftsman enough knowledge of drafting 
tools to create a basic drawing of their design. The drafting application supports the drafting of 
engineering models in accordance with ANSI standards. After exp
drafting application, we will go through a step
created earlier. 
 
 
5.1 OVERVIEW 
 

The Drafting Application is designed to allow you to produce and maintain industry standard 
engineering drawings directly from the 3D model or assembly part. Drawings created in the 
Drafting application are fully associative to the model and any changes made to the mo
automatically reflected in the drawing. The Drafting application also offers a set of 2D drawing 
tools for 2D centric design and layout
The DRAFTING Application is based on creating views from a
Drafting makes it easy to create drawings with orthographic views, section views, imported 
view, auxiliary views, dimensions and other annotations.
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CHAPTER 5 – DRAFTING 

The NX7 Drafting application lets you create drawings, views, geometry, dimensions, and 
drafting annotations necessary for the completion as well as understanding of a industrial 

wing. The goal of this chapter is to give the designer/draftsman enough knowledge of drafting 
tools to create a basic drawing of their design. The drafting application supports the drafting of 
engineering models in accordance with ANSI standards. After explaining the basics of the 
drafting application, we will go through a step-by-step approach for drafting some of the models 

Application is designed to allow you to produce and maintain industry standard 
engineering drawings directly from the 3D model or assembly part. Drawings created in the 
Drafting application are fully associative to the model and any changes made to the mo
automatically reflected in the drawing. The Drafting application also offers a set of 2D drawing 

layout requirements. You can produce standalone 2D drawings. 
Application is based on creating views from a solid model as illustrated below. 

makes it easy to create drawings with orthographic views, section views, imported 
view, auxiliary views, dimensions and other annotations. 

Missouri University of Science and Technology 

The NX7 Drafting application lets you create drawings, views, geometry, dimensions, and 
drafting annotations necessary for the completion as well as understanding of a industrial 

wing. The goal of this chapter is to give the designer/draftsman enough knowledge of drafting 
tools to create a basic drawing of their design. The drafting application supports the drafting of 

laining the basics of the 
step approach for drafting some of the models 

Application is designed to allow you to produce and maintain industry standard 
engineering drawings directly from the 3D model or assembly part. Drawings created in the 
Drafting application are fully associative to the model and any changes made to the model are 
automatically reflected in the drawing. The Drafting application also offers a set of 2D drawing 

requirements. You can produce standalone 2D drawings. 
solid model as illustrated below. 

makes it easy to create drawings with orthographic views, section views, imported 
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Some of the useful features of the Drafting Application are: 
1) After you choose the first view, the other orthographic views can be added and aligned 

with the click of some buttons. 
2) Each view is associated directly with the solid. Thus, when the solid is changed, the 

drawing will be updated directly along with the views and dimensions. 
3) Drafting annotations (dimensions, labels, and symbols with leaders) are placed directly 

on the drawing and updated automatically when the solid is changed. 
We will see how views are created and annotations are used and modified in the step-by-step 
examples. 
 
5.2 DRAFTING OF MODELS 
 

We will draft some models that have already been drawn. We will go through the drafting 
options step-by-step to make them easier to understand. 
 
5.2.1 Drafting  
 

� Open the file Arborpress_rack.prt  
 
� From the NX7 Interface Choose START           ALL APPLICATIONS → DRAFTING as 

shown 
 

 
 

* Note: All other applications such as Modeling, Manufacturing, Assembly, etc. can be opened 
in a similar fashion. 
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When you first open the Drafting Application, a window 

pops up asking for inputs like the Template, Standard 

Size or Custom Size, the units, and the angle of 

projection. 

Size 

Size allows you to choose the size of the Sheet. There 

are standard Templates that you can create for frequent 

use depending upon the Company Standards. There are 

several Standard sized Sheets available for you. You can 

also define a Custom sized sheet in case your drawings 

don’t fit into a standard sized sheet. 

Preview 

This shows the design of the Template 

Units 

Units follow the default units of the parent 3-D model. 

In case you are starting from the Drafting Application 

you need to choose the units here. 

Projection 

You can choose the projection method either first angle 

or third angle method. 

To start using the Drafting Application we will begin by 

creating a Standard Sized sheet 

� Click on the Standard Size radio button. 

� In the drop-down menu on the Size window, select 

sheet B, which has dimensions 11 x 17. Then change 

the scale to 1:25 by using the drop-down menu and 

choosing the Custom Scale under the Scale.  

� Click OK 

 

This will open the drafting option and the following 
screen will be seen as below. Let us first look at the 
Drafting Application Interface.  
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After this you will see another dialog box pops
which will define the Base View 
you do not see the figure on right then
 
� Choose INSERT → VIEW →

 
You can find a Dialog box with the options of the 
and the Scale of the view, as shown in the figure on 
your screen along with a floating drawing of t
 
� Choose the View to be FRONT
 
You can find the Front View projection on the screen. 
You can move the Mouse cursor on the screen and 
click on the place where you want the view. 
 
Once you set the Front view another dialog box will 
pop-up asking you to set the other views at any location 
on the screen within the Sheet Boundary
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After this you will see another dialog box pops-up 
Base View and its location. If 

you do not see the figure on right then 

 VIEW → BASE  

You can find a Dialog box with the options of the View 
of the view, as shown in the figure on 

your screen along with a floating drawing of the object. 

FRONT 

projection on the screen. 
You can move the Mouse cursor on the screen and 
click on the place where you want the view.  

view another dialog box will 
ou to set the other views at any location 

Sheet Boundary. 

Missouri University of Science and Technology 
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You can find the views by changing the cursor around the first view (FRONT VIEW). The 

following are some snap shots of the views seen at different location of the mouse cursor. If you 

want to add any orthographic views after closing this file or changing to other command modes  

� Choose INSERT → VIEW → PROJECTED VIEW 
 
Now let us create all the other orthographic projected views as shown below and click on the 
screen at the desired position.  
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� Keep on Clicking in the Sheet to create the side view.  
 

� In case you have closed the Projected View dialog box you can reopen it by clicking on the 
Projected View icon in the Drafting Layout Toolbar. 

 
 
 
 
 
 
 
� Move the cursor to the right side and click there to get the right-side view 
 

 

 

� Click Close on the Projected View dialog box or Press <Esc> key on the Keyboard to get out 
of the View creation.  

 

Before creating the dimensions, let us remove the borders in each view as it adds to the 

confusion with the entity lines.  

� Choose PREFERENCES → DRAFTING 
 
The Drafting Preferences window will pop up.  
� Click on the VIEW tab button 
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� Uncheck the Tick mark on the Display Borders as shown in the figure below and click OK 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Now you can find the drawing views without borders as shown below.  
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5.2.2 Dimensioning  
 

Now we have to create the dimensions for these views. The 

dimensions can be inserted by either of the two ways as 

described below:  

1) Choose INSERT → DIMENSION  
OR 

2) Click on the Dimension Toolbar as shown in the 
following figure 

     
� Choose INSERT → DIMENSION → INFERRED 
 

The following two option boxes will pop up. The icons on this 

toolbar are helpful for changing the properties of the 

dimensions.   

 

 

 

 

 

The first icon lists different styles of displaying the Nominal dimension and 
Tolerances as shown in the figure on the right. 
 
The second icon allows you to change the number of significant digits given 
in the dimension as shown in figure on right. For example, selecting ‘2’ will 
display the dimension till two decimal places as “240.00” while selecting ‘3’ 
will display the dimension till three decimal places as “240.000”. This is 
extremely useful when you are defining the tolerances of the part. 
 

The next icon is the annotation editor, which you can use to edit the 
dimension value. 
  
The last icon in the option bar resets these properties to default settings. Now 
we will create the first dimension. The Settings tab allows you to configure 
the settings of the dimension arrows, alignment, lettering in the annotation 
etc. as shown in the figures below. 
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� On the First view (FRONT View) that you created, click on the top left corner of the rack 

and then on the top right corner 
 

The dimension that represents the distance between these points will appear. You can put the 
location of the dimension by moving the mouse on the screen. Whenever you place your views 
in the Sheet please take into consideration that you will be placing the dimensions around it.  
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� To set the dimension onto the drawing sheet, place the dimension well above the view as 
shown and click the left mouse button 

 

 

Even after creating the dimension, you can edit the properties of the dimensions.  

� Right-click on the dimension you just created and Choose STYLE 
 

� Increase the Character Size to 0.2 and click OK 
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� Give dimensions to all other views as shown in the following figure  
 

 

5.2.3 Sectional View  
 

Let us create a Sectional View for the same part to show the depth and profile of the hole.  

� Choose INSERT → VIEW → SECTION VIEW 
 

� Click on the bottom of the Base View as Shown in the figure. This will show a Phantom 
Line with two Arrow marks for the direction of the Section plane (orange dashed line with 
arrows pointing upwards).  

 

� Click on the middle of the View as shown. 
 

This will fix the position of the sectional line (Section Plane). 

Now move the cursor around the view to get the direction of the Plane of section. Keep the arrow 

pointing vertically upwards and drag the sectional view to the bottom of the Base View.  
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Adjust the positions of dimensions if they are interfering. The Final Drawing sheet should look 

like the one shown in the following figure.  

 

 

 

Save and close your model.  
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5.2.4 Drafting and Dimensioning of an Impeller hexagonal bolt 
 

� Open the model Impeller_hexa-bolt.prt 
 

� Choose START → DRAFTING 
 

� On the New Drawing Sheet window, select sheet E-
34 X 44 and change the Numerator Scale value to 
8.0 

 
� Choose INSERT → VIEW → BASE VIEW 

 
� Add the FRONT view by repeating the same 

procedure as in the last example  
 
� Add the Orthographic Views, including the right 

side view and top view  
 
� Choose PREFERENCES → DRAFTING 

 
� Uncheck the box next to Display Borders under 

View Tab 
 
The screen will have the following three views: 
 

 
There are always the hidden lines, which are not seen. To see the hidden lines 
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� Choose PREFERENCES → VIEW OR 
 

� Select the views, right-click and choose STYLE as shown below 
 

 
 
A window will pop up with various options pertaining to the views.  
 
� Click on the Hidden lines tab 
 
� Change INVISIBLE to DASHED LINES as shown below and click OK 
 

  

You can see the hidden lines as shown below. 
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Now we will proceed to dimensioning.  
 
� Choose INSERT → DIMENSIONS → VERTICAL 
 
� Give vertical dimensions to all the distances shown below. 
 

 

 
Now we have to give the dimensions of the bolt head. 
 
� Choose INSERT → DIMENSIONS → PARALLEL 
 
� Give the two dimensions to the bolt head as shown in the 

figure. 
 
For the threading, we will use a leader line.  
 
� Click on the Text Symbol icon shown in the Toolbar 
 
 
 
 
� In the Annotation Editor window that opens, enter the following text exactly as shown. You 

can find Ø and the degree symbol on the Drafting Symbols tab  
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Right Hand Ø 0.20 X 1.5 
Pitch 0.05, Angle 600 

 
� Click on the threaded shaft in the side view, hold 

the mouse and drag the Leader line next to the 
view. Let go of the mouse and click again to 
place the text.  

 
� Close the Annotation Editor 
 

Since the height of the Lettering is small, we will 
enlarge the character size as well as the arrow size. 
 
� Right-click on the Leader and select STYLE 

 
� Click on the Lettering tab 
 
� Increase the Character Size to make the leader 

legible. 
 

Now we will add additional dimensions and views.  
 
� Choose INSERT → DIMENSIONS → 

DIAMETER  
 

� Click the circle of the bolt in the top view to give 
the diameter dimension  
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� Click INSERT → VIEW → BASE VIEW 
 

� Select the TFR-ISO view and place the view somewhere on the screen 
 
The final drawing is shown below. Remember to save.  

 

 

5.3 EXERCISE - DRAFTING AND DIMENSIONING OF A CIRCULAR BASE 
 

As an exercise, perform drafting and give dimensions to the circle base that you modeled in 

Exercise 4.4. The model of the part is displayed below.  
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CHAPTER 6 
 
In this chapter, you will learn how to create and edit sketches in NX7.  Sketchin
is much more user-friendly compared to its older versions. Unlike in NX5 where you could 
create sketch in Sketch environment, in NX7 you can directly create a sketch in 
Application. Up to this point, the only way you have learned 
and operating form features. In this second method of modeling, you will first create a sketch and 
then extrude, revolve or sweep the sketch to create solids. Many complex shapes that are 
otherwise very difficult to model using 
sketching. In this chapter, we will see some concepts of sketching and then proceed to sketch and 
model some parts. 
 

6.1 OVERVIEW 
 

An NX7 sketch is a named set of curves joined in a string 
sketch represents the outer boundary of that part. The curves are created on a plane in the 
sketcher. In the beginning, these curves are drawn without any exact dimensions. The solids 
created can be united into single par
1) Geometric constraints 
2) Dimensional constraints  
These will be discussed in detail later. 
 
These are the different ways that you can use sketches:
 

• A sketch can be revolved:
 
 
 
 
 
 

• A sketch can be extruded:

 

• A sketch can be swept along a guide (line):
 
 
Features created from a sketch are associated with it; if the 

sketch changes so do the features.
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CHAPTER 6 – SKETCHING 

In this chapter, you will learn how to create and edit sketches in NX7.  Sketching in NX7 version 
friendly compared to its older versions. Unlike in NX5 where you could 

environment, in NX7 you can directly create a sketch in 
Application. Up to this point, the only way you have learned to create a new model is by creating 
and operating form features. In this second method of modeling, you will first create a sketch and 
then extrude, revolve or sweep the sketch to create solids. Many complex shapes that are 

el using primitives or other form features can easily be drawn by 
sketching. In this chapter, we will see some concepts of sketching and then proceed to sketch and 

An NX7 sketch is a named set of curves joined in a string that when swept, form a solid. The 
sketch represents the outer boundary of that part. The curves are created on a plane in the 
sketcher. In the beginning, these curves are drawn without any exact dimensions. The solids 
created can be united into single parts using constraints. There are two kinds of constraints:

These will be discussed in detail later.  

These are the different ways that you can use sketches: 

A sketch can be revolved: 

 
 

can be extruded: 
 

 

 

A sketch can be swept along a guide (line): 

Features created from a sketch are associated with it; if the 

sketch changes so do the features. 
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g in NX7 version 
friendly compared to its older versions. Unlike in NX5 where you could 

environment, in NX7 you can directly create a sketch in Modeling 
to create a new model is by creating 

and operating form features. In this second method of modeling, you will first create a sketch and 
then extrude, revolve or sweep the sketch to create solids. Many complex shapes that are 

can easily be drawn by 
sketching. In this chapter, we will see some concepts of sketching and then proceed to sketch and 

that when swept, form a solid. The 
sketch represents the outer boundary of that part. The curves are created on a plane in the 
sketcher. In the beginning, these curves are drawn without any exact dimensions. The solids 

ts using constraints. There are two kinds of constraints: 



101 
NX7 for Engineering Design                                                                 Missouri University of Science and Technology 

The advantages of sketching over using primitives are:  
 

a) The curves used to create the profile outline are very flexible and can be used to model 
unusual shapes. 

b) The curves are parametric, hence associative and they can easily be changed or removed. 
c) If the plane in which the sketch is drawn is changed, the sketch will be changed 

accordingly.  
d) Sketches are useful when you want to control an outline of a feature, especially if it may 

need to be changed in the future. Sketches can be edited very quickly and easily. 
 

6.2 SKETCHING FOR CREATING MODELS 
 

In earlier chapters, we dealt with the Form Features and the Feature Operations. In this 
chapter, we will model complex shapes by using sketching. 
 
6.2.1 Model an Arbor Press Base 
 

� Create a new file and save it as Arborpress_base.prt 
 

In NX7 you can create sketch using two ways. The first 

method creates the Sketch in the current environment and 

application. For this you will have to use 

� Choose INSERT → SKETCH  
 

In the other method you can create Sketch using 
 
� Choose INSERT → SKETCH in TASK 

ENVIRONMENT 
 

In either of the case, it pop-ups a dialog box asking you to define the Sketch Plane. We will use 

second method of creating sketch. The screen will display the Sketch options. You can choose 

the sketch plane, direction of sketching and type of plane for sketching. The default sketch plane 

is the X-Y plane. When you create a sketch using the Create Sketch dialog box, you can choose 

the plane on which the sketch can be created by clicking on the coordinate frame as shown. This 

will highlight the plane you have selected. The default plane selected is XC-YC. 

Choose the XC-YC plane and click OK 

The sketch plane will appear and the X-Y directions will be marked. 

This is 2D sketching. 

The main screen will change to the Sketch Environment. The XY plane 

is highlighted as the default plane for sketching. However, you can 
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choose to sketch on another plane. If there are any solid features created in the model 

beforehand, any of the flat surfaces can also be used as a sketching plane.

  

This is the basic sketch window. It can be divided into various parts, which ha
 

 
You can change the name of the sketch in the box next to the Finish Flag.

6.2.1.1 Sketch Curve Toolbar 

 

This Toolbar contains icons for creating the common types of curves and Spline

extending, trimming, filleting etc. Each type of curve will have different methods of selection 

methods of creation. Let us discuss the most frequently used options.

  Profile:  

This option creates both straight lines as well as arcs dep

up toolbar. You can pick the points by using the coordinate system or by entering the length and 

angle of the line as shown in the following figures.
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choose to sketch on another plane. If there are any solid features created in the model 

beforehand, any of the flat surfaces can also be used as a sketching plane. 

This is the basic sketch window. It can be divided into various parts, which have been labeled.

You can change the name of the sketch in the box next to the Finish Flag. 

 

This Toolbar contains icons for creating the common types of curves and Spline

extending, trimming, filleting etc. Each type of curve will have different methods of selection 

methods of creation. Let us discuss the most frequently used options. 

This option creates both straight lines as well as arcs depending on the icon you select in the pop

up toolbar. You can pick the points by using the coordinate system or by entering the length and 

angle of the line as shown in the following figures. 

Missouri University of Science and Technology 

choose to sketch on another plane. If there are any solid features created in the model 

ve been labeled. 

 

This Toolbar contains icons for creating the common types of curves and Spline curves, editing, 

extending, trimming, filleting etc. Each type of curve will have different methods of selection 

ending on the icon you select in the pop-

up toolbar. You can pick the points by using the coordinate system or by entering the length and 
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  Line:  

This option will selectively create only straight lines. 

  Arc:   

This option creates arcs by either of two methods. The first option creates arc with three 

sequential points as shown below. 

 

The second option creates the arc with a center point, radius and sweep angle or by center point 

with a start point and end point. The illustration is shown below: 

 

  Circle:  

Creating a circle is similar to creating an arc, except that circle is closed unlike an arc. 

  Quick Trim:    

This trims the extending curves from the points of intersection of the curves. This option reads 

every entity by splitting them if they are intersected by another entity and erases the portion 

selected. 

  Studio Spline:       

You can create basic spline curves (B-spline and Bezier) with poles or through points with the 

desired degree of the curve. The spline will be discussed in detail in the next chapter (Freeform 

Features).  
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6.2.1.2 Constraints Toolbar 

 

All the curves are created by picking points. For example, a straight line is created with two 
points. In a 2-D environment, any point will have two degrees of freedom, one along X and 
another along Y axis. The number of points depends on the type of curve being created. 
Therefore, a curve entity will have twice the number of degrees of freedom than the number of 
points it comprises. These degrees of freedom can be removed by creating a constraint with a 
fixed entity. In fact, it is recommended that you remove all these degrees of freedom by relating 
the entities directly or indirectly to the fixed entities. It can be done by giving dimensional or 
geometric properties like Parallelity, Perpendicularity, etc. In NX7 smart constraints are applied 
automatically, i.e. automatic dimensions or geometrical constraints are interpreted by NX7. 

(Note: Any degrees of freedom that are not constrained are displayed in orange arrows . All 
these arrows should be removed by applying the constraints to follow a disciplined modeling.) 

  Dimensional Constraints:  

The degrees of freedom can be eliminated by giving dimensions with fixed entities like axes, 
planes, the coordinate system or any existing solid geometries created in the model. These 
dimensions can be linear, radial, angular etc. You can edit the dimensional values at anytime 
during sketching by double-clicking on the dimension. 

  Geometric Constraints: 

Besides the dimensional constraints, some geometric constraints can be given to eliminate the 
degrees of freedom. They include parallel, perpendicular, collinear, concentric, horizontal, 
vertical, equal length, etc. The software has the capability to find the set of possible constraints 
for the selected entities.  

  Show all Constraints: 

Clicking this icon will show all the options pertaining to the entities in that particular sketch in 
white.  
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  Show/Remove Constraints:  

This window lists all the constraints and types of constraints pertaining to any entity selected. 
You can delete any of the listed constraints or change the sequence of the constraints.  

6.2.1.3 Sketcher Toolbar  

 
Besides being able to change the name of the Sketch, the sketcher toolbar also has some other 
highly useful features mentioned below. 

  Orient View to Sketch: 

If the model file is rotated during the process of sketching, click on this icon to view the sketch 
on a plane parallel to the screen. 

  Reattach Sketch: 

This function allows you to reattach the sketch to the desired plane without recreating all the 
curves, dimensions, and constraints.  

  Update Model: 

When you make changes in a sketch, click on this icon to see the effects of those changes 
without exiting the Sketch mode.  

Now we will draw curves using the options discussed above.  

� Choose INSERT → PROFILE if the Profile window is not already showing.   
 
� Draw a figure similar to the one shown below. While 

making continuous sketch, click on the Line icon on 
the Profile dialog box to create straight lines and the 
Arc icon to make the semicircle. (Look at the size of 
the XY plane in the figure. Use that perspective for the 
approximate zooming.) 

 

Once the sketch is complete, we will constrain the sketch. It 
is better to apply the geometric constraints before giving 
the dimensional constraints. 
  
� Choose INSERT → CONSTRAINTS or click on the 

Constraints icon in the side toolbar     
 
You will be able to see all the degrees of freedom on the screen represented by orange arrows.  
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Note the automatic dimension constraints being applied to each entity. Now we will start by 
constraining between an entity in the sketch and the datum or fixed reference. Note that when the 
figure is not completely constrained it will appear light green. 
 
We will first place the center of the arc at the origin. This creates a reference for the entire figure. 
We can use the two default X and Y axes as a datum reference. 
 
� Select the Y-axis and then the center of the arc, which is marked by the ‘+’ sign. The center 

of the arc will be marked by a red asterisk once it has been selected. 
 

� Click the Point on Curve icon 
 

� Repeat the same procedure to place the center of 
the arc on the X-axis  

 
Do not worry in case the figure gets crooked. The 
figure will come back to proper shape once all the 
constraints are applied. Note that when you initially 
draw the unconstrained figure, that into consideration 
the final shape of the object. 
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� Select the two slanted lines and make them equal in length 
 

 
 
� Similarly select the two long vertical lines and make them equal in length 

 

 
 
� Select the bottom two horizontal lines and make them collinear and then click on the same 

lines and make them equal in length  
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If you DO NOT find the two Blue circles (Tangent Constraints) near the semicircle as shown in 
the figure, follow the below steps. Otherwise, you can ignore this and skip down to the 
dimensional constraints. 
 

 
 
� Select the circular arc and one of the two vertical lines connected to its endpoints 

 

� Select the Tangent icon  
 
If the arc and line is already tangent to each other, the icon will be grayed out. If that is the case 
click on EDIT → SELECTION →, DESELECT ALL. Repeat the same procedure for the arc 
and the other vertical line. 
 

 
 
� Select the two vertical lines and make them equal 
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� Similarly select the two small horizontal lines and make them collinear and equal 
 

 
 

� Similarly select the two vertical lines and make them equal 
 

 
 
So far, we have created all the Geometric constraints. Now we have to create the Dimensional 

constraints. You will find that as we add on dimensions, the degrees of freedom represented by 
the yellow arrows will disappear. NX7 will not allow duplication of dimensions. This is why it is 
better to apply the geometric constraints first. If there is any conflict between the dimensional 
and geometric constraints, those entities will be highlighted in yellow.  
 
� Choose the Inferred Dimensions icon in the Constraints toolbar 

 

� Add on all the dimensions as shown in the following figure 
 

For example, to create a dimension for the top two corners, you may have to click on the arrow 
next to the Inferred Dimensions icon and click on the Horizontal icon. Then click somewhere 
near the top of the two diagonal lines to select them. While dimensioning, if you find the 
dimensions illegible, but do not worry about editing the dimensions now. Make sure the small 
arrows are disappearing as constraints are placed.  
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Now we will edit all the dimension values one by one. It is highly recommended to start editing 
from the biggest dimension first and move to the smaller dimensions. 

� Edit the values as shown in the figure below. Double click on each dimension to change the 
values to the values as shown in figure below: 
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� Click on the Finish flag  on the top left corner of the screen when you are finished  
 

� Click on the sketch and right-click 
 
� Click INSERT → DESIGN FEATURE → EXTRUDE  
 

 
 
� Extrude this sketch in the Z-direction by 60 inches 
 

 
 

� Create a hole with a diameter of 4 inches and a height of 30 inches at the point (0, 35, 0) 
from the WCS 

The final figure is shown below. Save and close the file.  
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6.2.2 Model an Impeller Lower Casing 
 

� Create a new file and save it as Impeller_lower-casing.prt 
 
� Click on INSERT → SKETCH in TASK ENVIRONMENT 

 
� Set the sketching plane as the XC-YC plane 

� Make sure the Profile window is showing and draw the following curve  
 

 

 

� Click INSERT → DATUM/POINT  
 

� Create a point at the origin (0, 0, 0) and click OK 
 

� Click Close to exit the POINT CONSTRUCTOR window 
 
Next, we will constrain the curve. 

Line 1 

Curve 2 

Curve 1 

Line 2 
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� Click on the Geometric Constraints icon  
 

� Select the point at the origin and click on the Fixed  constraint 
icon  

 

� Make all of the curve-lines and curve-curve joints tangent 
 

� Then apply the dimensional constraints as shown in the figure below: 
 

 

 
� Select all the dimensions. Right click and Hide the 

dimensions 
 

� Choose EDIT →→→→ MOVE OBJECT  

 
� Select all the curves. You should see ‘4’ objects 

being selected in Select Object 
 

� Specify the Motion to be Distance 
 

� Choose –YC-Direction in the Specify Vector 
 

� Enter the Distance to be 0.5 inch 
 

� In the Result dialog box make sure you the click on 
the Copy Original radio button 

 
� Click OK 
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� Click Cancel to get out of the MOVE OBJECT dialog box 
 

Do not hit OK again otherwise the distance increases every time you hit OK. 

� Then join the end-points at the two ends using the basic curves to complete the sketch 
 

 

 
The sketch is ready.  
 
� Choose EDIT → MOVE OBJECT 
 
� Select the outer curve as shown in the figure below. Be sure to select all the four parts of the 

curve. 
 

� Move the lower curve in the Y-direction by -1.5 inches. This is the same as translating it in 
the negative YC-direction by 1.5 inches 

 

 

This will form a curve outside the casing. 
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� Using straight lines join this curve with the inside curve of the casing 
 
It will form a closed chain curve as shown. 
 

 

 

Now we will create the curve required for outside of the 

casing on the smaller side which will form the flange 

portion. 

� Choose EDIT → MOVE OBJECT 
 
Select the outer curve as shown in the figure on the 

right. 

� Move the lower curve in the XC-direction by -0.5 
inches. This is the same as translating it in the 
negative XC-direction by 0.5 inches 

 

� Using straight lines join the two lines as shown in 
the figure on right side 
 

� Click on the Finish Flag  
 
 

� Click on INSERT → DESIGN FEATURE → REVOLVE 
 
Make sure that the Selection Filter is set to Single Curve as shown below on 
the Selection Filter Toolbar 
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� Click on each of the 10 
curves as shown  
 

� In the Axis dialog box , 
in the Specify Vector 
option choose the 
positive XC-direction 
 

� In the Specify Point 
option, enter the 
coordinates (0, 0, 0) so 
the curve revolves 
around XC-axis with 
respect to the origin 
 

� Keep the Start Angle as 
0 and enter 180 as the 
value for the End Angle 
 

� Click OK 
 

The solid is seen as below. 
 

 

 
Now, we will create edges. 

 

� Click on INSERT → DESIGN FEATURE → EXTRUDE 
 

� Select the outer curve of the casing as shown in the figure below.  
 

Again make sure that the Selection Filter is set to Single Curve. 



117 
NX7 for Engineering Design                                                                 Missouri University of Science and Technology 

� In case you are not able to select the proper lines then 
left-click and hold the mouse button and you will see a 
dialog box pop-up, which will provide you the options 
of which curve to select as shown 
 

� Select the curve you just created in the second Sketch 
 

� Extrude this piece in the negative Z-direction by 0.5 
inches 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The final solid will be seen as follows. 
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We will now use the Mirror option to create an edge on the other side. 
 

� Choose EDIT →→→→ TRANSFORM  

 
� Select the solid edge as shown. For this you will have to change the Filter in the dialog box 

to Solid Body 
 

 

 

� Choose MIRROR THROUGH A PLANE  
 

� Under Principal Planes, click on the XC-ZC icon as 
shown and click OK 

 
� Select COPY 
 
� Click Cancel 
 
 The edge will be mirrored to the other side as shown below. 
 

 

 
We will create an edge at the smaller opening of the casing as shown. 
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� Click on INSERT → DESIGN FEATURE → REVOLVE 

 
Again make sure that the Selection Filter is set to Single Curve. The default Inferred Curve 
option will select the entire sketch instead of individual curves. 

 
� Revolve this rectangle in the positive XC-direction relative to the Origin just like for the 

casing. The End Angle should be 180 
 
This will form the edge as shown below. 
 

 

 

The lower casing is complete. Save the model. 
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6.2.3 Model an Impeller 
 

Create a new file and save it as Impeller_impeller.prt 
 
� Click on INSERT → SKETCH 

 
� Set the sketching plane as the XC-YC plane 

 
� Click on INSERT → POINT 

 
� Create two Points, one at the origin (0, 0, 0) and one at (11.75, 6, 0) 

 
� Click on the Arc icon on the side toolbar and click on the Arc by Center and Endpoints 

icon  in the pop-up toolbar 
 

� Click on the point at the origin and create an arc with a Radius of 1.5 similar to the one 
shown in the figure below 
 

� Click on the point at (11.75, 6, 0) and create an arc with a radius of 0.5 
 

 
 
 
 
 
 
 
 
 
 
 
 

� Click on the Arc by 3 Points icon  in the pop-up toolbar  
 
� Select the top endpoints of the two arcs you just created and click somewhere in between to 

create another arc that connects them. Do the same for the bottom endpoints 
 

� Click on the Constraints icon in the side toolbar and make sure that all the arcs are tangent 
to one another at their endpoints 

� Click on the point at the origin and click on the Fixed  icon 
 
The sketch should look like the following. 
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� Then click on the Inferred Dimensions icon 
 
� Give the Radius dimensions for each arc. Edit dimensions so that the two arcs on the end are 

1.5 and 0.5 inches and the two middle arcs are 18 and 15 inches as shown in the figure 
below: 

 

 

� Select the Parallel dimensioning option from the Dimensions drop-down menu 
 

� Create a dimension giving the distance between the origin point and the other point and edit 
the distance to be 13.19 inches 
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� Click on the Finish Flag   
 
Now the sketch is ready as shown below. 
 

 

 

Now let us model a cone. 
 
� Choose INSERT → DESIGN FEATURE → CONE 
 
� Select DIAMETERS, HEIGHT 
 
� Select the –XC-Direction in the Specify Vector dialog 

box 
 

� In the Point Constructor, enter the coordinates (14, 0, 
0) in the Specify Point dialog box 

 
� Enter the following dimensions: 
 Base Diameter = 15 inches 
 Top Diameter = 8 inches 
 Height = 16.25 inches 
 
The cone will be seen as shown below. 
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� Extrude the aerofoil curve in the Z-direction by 13 inches. Unite the two solids in the 

Boolean operation dialog box 
 

The model will be as follows. 

 

Now let us create five instances of this blade to make the impeller blades. 
 
� Click on INSERT → ASSOCIATIVE COPY → INSTANCE FEATURE 
 

� Select CIRCULAR ARRAY 
 

� Select EXTRUDE 
 

� For Number, type in 5 and for Angle, enter 72.  
 

� Click OK 
 

� Select POINT, DIRECTION 

 

� Select the XC-Direction for the Specify Vector and the Origin for the Specify Point  
 

� Click YES 
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The model will be seen as follows. 

 

Now let us create two holes in the cone for the shaft and the locking pin. Note that these holes 
can also be created by HOLE menu option. 
 
� Subtract a cylinder with a diameter of 4 inches and a height of 16 inches from the side of 

the cone with the larger diameter as shown 
 

� Subtract another cylinder with a diameter of 0.275 inches and a height of 0.25 inches from 
the side of the cone with the smaller diameter 
 

The final model will look like the following. Save your work.  
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6.3 EXERCISES  
 

Exercise 1 - Model an Impeller Upper Casing: 
 
As an exercise, model the upper casing of the Impeller as shown below. 
 

 
 
The dimensions of the upper casing are the same as for the lower casing, which is described in 
the previous exercise in detail. The dimensions for the manhole should be such that impeller 
blades can be seen and a hand can fit inside to clean the impeller.  
 
Exercise 2 - Modeling a Die-Cavity: 
 
Model the following part to be used for the Chapter 9 Manufacturing Module. Create a new file 
‘Die_cavity.prt’ with units in mm not in inches. Create a rectangular Block of 150, 100, 40 
along X, Y and Z respectively with the point construction value of (-75,-50,-80) about XC, YC 
and ZC.  
 
Create and Unite another block over the first one with 100, 80 and 40 along X, Y and Z. and 
centrally located to the previous block. 
 
Create a sketch as shown below including the spline curve and add an Axis line. Dotted lines are 
reference lines. While sketching, create them as normal curves. Then right click on the curves 
and change display property into Phantom lines (Dashed Dot) lines. Give all the constraints and 
dimensions as shown in the figure below.  
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Revolve the curves about the dashed axis as shown above, and subtract the cut with start angle 
and end angle as -45 and 45.  
 
Subtract a block of 70, 50, and 30 to create a huge cavity at the centre. Create and Unite 4 
cylinders at the inner corners of the cavity with 20 inches diameter and 15 inches height.  
 

   
 
 
Add edge blends at the corners as shown in the final Model below. Keep the value of blend as 10 
radii for outer edges and 5mm radii for the inner edges. 
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CHAPTER 7 – FREEFORM FEATURE 
 

In this chapter, you will learn how to create freeform models in NX7.  Up to this point, you have 
learned different ways to create models by using Form Features or by Sketch. Freeform 
modeling involves creating solids in the form of surfaces particularly the B-surface. Because of 
their construction techniques and design applications, these surfaces are usually stylistic. A few 
freeform features are shown below.  
 

 
 
To create Freeform Features, you must first need a set of points, curves, edges of sheets or 
solids, faces of sheets or solids, or other objects. The following topics will cover some of the 
methods that you can use to create solids using some of the freeform features.  

 
7.1 OVERVIEW 
The Freeform Features in NX7 are grouped under various menus and located in the INSERT 
menu. There are a lot of ways in which you can create Freeform Features from the existing 
geometry you have like points, edges, curves, etc. A few of the menus are discussed below.  

7.1.1 Creating Freeform Features from Points  
In the case where the geometry you are constructing or pre-existing data includes only points, 
you may be able to use one of these three options to build the feature from the given points. 
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� Click on INSERT → SURFACE
  

•  From Point Cloud - if you 
have scattered points in the form of 
cloud.  

 

  Through Points – if the points 
form a rectangular array. 

  

•   From Poles - if defined points 
form a rectangular array tangential to 
the lines passing through them. 

 
 
 
 
 
 
 
 
 

7.1.2 Creating Freeform Features from Section Strings 
 

If construction geometry contains strings of connected objects (curves and edges), you may be 
able to use one of these two options to build the feature. 
 
� Click on INSERT → MESH SURFACE
 

•   Ruled – Used if the two strings 
are roughly parallel.  
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SURFACE 

if you 
have scattered points in the form of 

if the points 

if defined points 
form a rectangular array tangential to 

through them.  

7.1.2 Creating Freeform Features from Section Strings  

If construction geometry contains strings of connected objects (curves and edges), you may be 
able to use one of these two options to build the feature.  

MESH SURFACE 

Used if the two strings 

 

Missouri University of Science and Technology 

 

If construction geometry contains strings of connected objects (curves and edges), you may be 
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•   Through Curves – Used if the three or more strings are roughly parallel.  
 

 
 
If construction geometry contains two or more strings (curves, faces, edges) that are roughly 
parallel to each other, and one or more section strings that are roughly perpendicular to the first 
set of curves (guides), you may be able to use one of these following options to build the feature.  

 

•   Through Curve Mesh – Used if at least four section strings exist with at least two 
strings in each direction (parallel and perpendicular).  

 

 
 
If the two sections are perpendicular then choose INSERT → SWEEP 

•   Swept – Used if at least two section strings are roughly perpendicular.  
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7.1.3 Creating Freeform Features from Faces  
 
If the construction geometry contains a sheet or face, you may be able to use one of the 
following three options to build the feature.  
 
� Click on INSERT → OFFSET/SCALE 
 

•   Offset Surface – Use this option if you have a face to offset.  
 

 
 

� Click on the INSERT → SURFACE → EXTENSION 
 

•   Extension – Use this option if you have a face and edges, edge curves, or curves on 
the face.  

 

 
 

7.2 FREEFORM FEATURE MODELING 
 

Let us do some freeform modeling on structured points, a point cloud, curves and faces. 
Structured points are a set of point’s defined rows and columns. A point cloud has a set of 
scattered points that form a cloud.  
 
7.2.1 Modeling with points 
 

� Open the file freeform_thrupoints.prt 
 

� Right-click on the Toolbars and make sure the SURFACE Toolbar is checked 
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You will see seven rows with many points. 
 

 

 

� Choose INSERT →→→→ SURFACE →→→→ THROUGH POINTS 
 
OR 

� Click on the Icon   in the Toolbar 
 
The dialogue box will pop up as shown in the right. 

 

� For Patch Type, select Multiple 
 

� For Closed Along, select Neither 
 

� For Row Degree and Column Degree, enter 3.  
 
� Click OK  

 
The next dialogue box will be as shown. 
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� Click CHAIN FROM ALL 
 

� Select the top starting point and the bottom ending point of the left most row as shown in the 
following figure 
 

 
 
The first row of points will be highlighted. 
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Repeat the same procedure to select the first four strings of points. After that, a window should 
pop up asking if all points are specified or if you want to specify another row.  
 

 

 

� Select SPECIFY ANOTHER ROW until all rows are specified 
 

� When all the rows are specified, choose ALL POINTS SPECIFIED 
 

� Click CANCEL on the Through Points 
window 

� Click on the Shaded icon  
 

You will see the surface as shown below. 

 Do NOT save these files.  
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7.2.2 Modeling with a point cloud 
 

� OPEN the file named freeform_cloud.prt 
 
The point cloud will be seen as follows. 
 

 

� Choose INSERT →→→→ SURFACE →→→→ FROM POINT CLOUD or click on this icon  on 
the Surface Toolbar 

 

The following dialogue box will appear. 
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At the bottom of the window, you can see the option Confirm Upon Apply. This option lets you 
view and analyze the feature before you create it.  
 
� Uncheck the Confirm Upon Apply box  

 
� Select all the points on the screen by dragging a rectangle around them 
 
After you have selected the points, the screen will look like the following. 
 
 

 
 

� In the Coordinate System drop-down menu, choose WCS for the Coordinate System. This 
matches the point cloud coordinate system with original system  
 

� Under Boundary, choose Minimum Box. This is the boundary for the point cloud 
 

� Keep the default values for U and V Degree as 3 
 

� Click OK 
 

� Change the VIEW to Shaded to see the model as a solid 
 
The final sheet will look like the following. Again, do NOT save these files. 
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7.2.3 Modeling with curves 
 

� OPEN the file named freeform_thrucurves_parameter.prt  
 

The curves will be seen as in the figure on the right. 
 
 
 
 
 
 
 
 
 
 
 
 

� Choose INSERT →→→→ MESH SURFACE →→→→ THROUGH CURVES or click on this Icon 

 on the Toolbar 
 

� Select the first section string as shown below. Be sure to select somewhere on the left side of 
the arc. 

 
A direction vector displays at the end of the string.  
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You should see the screen as shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
� Click the middle mouse button MB2 
 
� Click on the next curve similar to first one and click the middle mouse button MB2. You can 

see a surface generated between the two curves as shown in the figure 
 

 
 

Repeat the same procedure to select the remaining strings. Remember to click MB2 after 
selecting each curve. 
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In the Alignment and Output Surface dialog box, 
choose the following: 
 
� For Patch Type, choose Single  

 
� For Alignment, choose Parameter 

 
� For Construction, choose Simple  

 
When the Simple option is activated, the system tries 
to build the simplest surface possible and minimize the 
number of patches.  
 
� Click OK  
 
If you are not able to see the surface then click on the 
Shade icon on the toolbar  
 

 
 
The following curved surface will be generated. 
Again, do not save the file.  
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7.2.4 Modeling with curves and faces
 
Open the file named freeform_thrucurves_faces.prt
 
The curve and faces will be seen as follows. 
 

� Choose INSERT →→→→ MESH SURFACE

THROUGH CURVES 
 

� Select the left edge of the top plane as shown below 
and click MB2 

 
� Now select the middle edge and click 

 
 
 
 
 
 
 
 
 
 
 
 
� In the Settings Dialog box, uncheck the 
 
You would get the following shape displayed on screen.
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7.2.4 Modeling with curves and faces 

freeform_thrucurves_faces.prt  

The curve and faces will be seen as follows.  

MESH SURFACE →→→→ 

Select the left edge of the top plane as shown below 

Now select the middle edge and click MB2 

Dialog box, uncheck the Preserve Shape check box 

You would get the following shape displayed on screen. 
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Make sure that all the arrows are pointing in the same direction. If not, click 
reselect the strings.  
 
� In the Alignment dialog box choose 
 
� In the Continuity dialog box select 

top plane as shown 
 

 

 
 

 
 
 
� Click APPLY 
 
 
 
 
 
 
 
 
 
 
 
 
 
� Now select the middle edge and click 
 
� Select the edge of the lower plane and click 

MB2 
 
� Click MB2 to finish the curve selection
 
� Change the option to G2 (Curvature) 

Continuity dialog box 
 
� Select the three faces of the lower surface as 

shown and click MB2 
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Make sure that all the arrows are pointing in the same direction. If not, click 

dialog box choose Parameter 

dialog box select G2 (Curvature) option and select the two faces of the 

 
 

 
 
 

Now select the middle edge and click MB2 

Select the edge of the lower plane and click 

to finish the curve selection 

G2 (Curvature) in the 

Select the three faces of the lower surface as 

Missouri University of Science and Technology 

Make sure that all the arrows are pointing in the same direction. If not, click CANCEL and 

option and select the two faces of the 
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� Select the face you just created for the continuity constraint for first section as shown above
 
� Click APPLY and then click 
 
The final curve will be seen as shown below. Do not save the files.
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Select the face you just created for the continuity constraint for first section as shown above

and then click CANCEL 

curve will be seen as shown below. Do not save the files. 

 

Face for first 

section 

Missouri University of Science and Technology 

 

Select the face you just created for the continuity constraint for first section as shown above 
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7.3 EXERCISE - MODEL A MOUSE 
 

Model a computer mouse similar to the one shown below or use your imagination to model a 
different mouse. As a hint, create some boundary curves on different planes and use them to 
form freeform surfaces. Use these quilt surfaces to create the solid. Add and subtract blocks and 
pads to attach the accessories like buttons.  
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CHAPTER 8 
 

This chapter introduces assembly modeling. Every day, we see many examples of components 
that are assembled together into one model such as bicycles, cars, and computers. All of these 
products were created by designing and manufacturing individual parts an
together. The designers who create them have to carefully plan each part so that they all fit 
together perfectly in order to perform the desired function. 
 
In this chapter, you will be learning two kinds of approaches used in 
will practice assembly modeling using the impeller assembly as an example. Some parts of this 
assembly have already been modeled in earlier chapters. 
 

8.1 OVERVIEW 
 

NX7 Assembly is a part file that contains the individual parts. They are added to the part file in 
such a way that the parts are virtual in the assembly and linked to the original part. This 
eliminates the need for creating separate memory space for the individual par
All the parts are selectable and can be used in the design process for information and mating to 
insure a perfect fit as intended by the designers. The following figure is a schematic, which 
shows how components are added to make an ass
 

 

8.2 TERMINOLOGIES 
 

Assembly 

An assembly is a collection of pointers to piece parts and/or subassemblies. An assembly is a 
part file, which contains component objects.
 

Component Object 

A component object is a non
pointer to the part file that contains the 
component geometry. Component Object

stores information such as the Layer

Reference set, position data for component 

relative to assembly and path of the 

component part on file system. 
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CHAPTER 8 – ASSEMBLY MODELING 

This chapter introduces assembly modeling. Every day, we see many examples of components 
that are assembled together into one model such as bicycles, cars, and computers. All of these 
products were created by designing and manufacturing individual parts and then fitting them 
together. The designers who create them have to carefully plan each part so that they all fit 
together perfectly in order to perform the desired function.  

In this chapter, you will be learning two kinds of approaches used in Assembly

will practice assembly modeling using the impeller assembly as an example. Some parts of this 
assembly have already been modeled in earlier chapters.  

is a part file that contains the individual parts. They are added to the part file in 
such a way that the parts are virtual in the assembly and linked to the original part. This 
eliminates the need for creating separate memory space for the individual parts in the computer. 
All the parts are selectable and can be used in the design process for information and mating to 
insure a perfect fit as intended by the designers. The following figure is a schematic, which 
shows how components are added to make an assembly.   

 

An assembly is a collection of pointers to piece parts and/or subassemblies. An assembly is a 
part file, which contains component objects. 

A component object is a non-geometric 
pointer to the part file that contains the 

Component Object 
Layer, Color, 

position data for component 

path of the 
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This chapter introduces assembly modeling. Every day, we see many examples of components 
that are assembled together into one model such as bicycles, cars, and computers. All of these 

d then fitting them 
together. The designers who create them have to carefully plan each part so that they all fit 

Assembly modeling. We 
will practice assembly modeling using the impeller assembly as an example. Some parts of this 

is a part file that contains the individual parts. They are added to the part file in 
such a way that the parts are virtual in the assembly and linked to the original part. This 

ts in the computer. 
All the parts are selectable and can be used in the design process for information and mating to 
insure a perfect fit as intended by the designers. The following figure is a schematic, which 

An assembly is a collection of pointers to piece parts and/or subassemblies. An assembly is a 
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Component Part 

A component part is a part file pointed to by a 
geometry is stored in the component part and is 
 
Component Occurrences 
An occurrence of a component is a pointer to geometry in the component file. Use component 
occurrences to create one or more references to a component without creating additional 
geometry. 
 
Reference Set 
A reference set is a named collection of objects in a component part or subassembly that you 
can use to simplify the representation of the component part in higher level assemblies.
 

8.3 ASSEMBLY MODELS
 

There are two basic ways of creating any assembly model.
 

• Top-Down Approach  

• Bottom-Up Approach  
 
8.3.1 Top-Down Approach 
 

The assembly part file is created first and components are created in that file. Then individual 
parts are modeled. This type of modeling is useful in a new design.
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is a part file pointed to by a component object within an assembly. The actual 
geometry is stored in the component part and is referenced, not copied by the assembly.

a component is a pointer to geometry in the component file. Use component 
occurrences to create one or more references to a component without creating additional 

is a named collection of objects in a component part or subassembly that you 
can use to simplify the representation of the component part in higher level assemblies.

8.3 ASSEMBLY MODELS 

ays of creating any assembly model.  

The assembly part file is created first and components are created in that file. Then individual 
parts are modeled. This type of modeling is useful in a new design. 
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within an assembly. The actual 
by the assembly. 

a component is a pointer to geometry in the component file. Use component 
occurrences to create one or more references to a component without creating additional 

is a named collection of objects in a component part or subassembly that you 
can use to simplify the representation of the component part in higher level assemblies. 

The assembly part file is created first and components are created in that file. Then individual 
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8.3.2 Bottom-Up Approach 
 

The component parts are created first in the traditional way and then added to the assembly part 
file. This technique is particularly useful, when part files already exist from the previous designs, 
and can be reused.  
 

 

8.3.3 Mixing and Matching 
 

You can combine these two approaches, when necessary, to add flexibility to your assembly 
design needs.  
 

8.4 ASSEMBLY NAVIGATOR
 
The Assembly Navigator is located on top of the Part Navigator in the Resource Bar on the left 
of the screen. The navigator shows you various things that form the assembly, including part 
hierarchy, the part name, information regarding the part such as whether the part is read only, the 
position, which lets you know whether the part is constrained using assembly constraints or 
mating condition, and the reference set. Following is a list of interpretation of the Position of the 
components. 
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The component parts are created first in the traditional way and then added to the assembly part 
file. This technique is particularly useful, when part files already exist from the previous designs, 

 

You can combine these two approaches, when necessary, to add flexibility to your assembly 

ASSEMBLY NAVIGATOR 

The Assembly Navigator is located on top of the Part Navigator in the Resource Bar on the left 
shows you various things that form the assembly, including part 

hierarchy, the part name, information regarding the part such as whether the part is read only, the 
position, which lets you know whether the part is constrained using assembly constraints or 
mating condition, and the reference set. Following is a list of interpretation of the Position of the 

Missouri University of Science and Technology 

The component parts are created first in the traditional way and then added to the assembly part 
file. This technique is particularly useful, when part files already exist from the previous designs, 

You can combine these two approaches, when necessary, to add flexibility to your assembly 

The Assembly Navigator is located on top of the Part Navigator in the Resource Bar on the left 
shows you various things that form the assembly, including part 

hierarchy, the part name, information regarding the part such as whether the part is read only, the 
position, which lets you know whether the part is constrained using assembly constraints or 
mating condition, and the reference set. Following is a list of interpretation of the Position of the 
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 - Indicates a fully constrained component 

- Indicates a fully mated component 

- (Fixed) Indicates that all the degrees of freedom are constrained 

- Indicates partially constrained component 

 - Indicates partially mated component 

 - Indicates that the component is not constrained or mated 

 

8.5 MATING CONDITIONS 
 

After the component objects are added to the assembly part file, each component object is mated 
with the existing objects. By assigning the mating conditions on components of an assembly, you 
establish positional relationships, or constraints, among those components. These relationships 
are termed mating constraints. A mating condition is made up of one or more mating 
constraints. There are different mating constraints as shown below: 

 

• Touch/Align – Planar objects selected to align will be coplanar but the normals to 
the planes will point in the same direction. Centerlines of cylindrical objects will be in 
line with each other. This is same as the Mate in NX5. 

 

• Angle – This fixes a constant angle between the two object entities chosen on the 
components to be assembled. 
 

• Bond – Creates a weld and welds components together to move as single object. 
 

• Parallel – Objects selected will be parallel to each other. 
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• Perpendicular – Objects selected will be perpendicular to each other. 
 

• Center – Objects will be centered between other objects, i.e. locating a cylinder 
along a slot and centering the cylinder in the slot. 
 

• Concentric - Constrains circular or elliptical edges of two components so the centers 
are coincident and the planes of the edges are coplanar. 

 

• Distance – This establishes a +/- distance (offset) value between two objects 
 

The Mating Conditions dialog box is shown on right. 
 

 

 

8.6 IMPELLER ASSEMBLY 
 

We will assemble the impeller component objects. All the part files will be provided to you.  
 
� Create a new file and save it as Impeller_assembly.prt  

 
� Choose APPLICATION → MODELING 
 
� Click on APPLICATION again and make sure there is a check mark next to 

ASSEMBLIES. If not, click on it  
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A new toolbar will appear on the screen as shown below. 
 

 

� Click on ASSEMBLIES from the menu bar 
 

 

We will be mostly using the COMPONENTS option, which includes:  

• ADD COMPONENT – This option adds new component objects whose part files are 
already present. 
 

• CREATE COMPONENT – This option lets you create new component geometries 
inside the assembly file in case you are using Top-Down approach of assembly. 
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The component position menus allow you to create 
assembly constraints and allow you to reposition the 
components wherever you want them in the assembly. 

• MOVE COMPONENT – Allows you to move 
and reposition component objects.  
 

• ASSEMBLY CONSTRAINTS – They are used 
to mate or align the component objects. 

 

� Choose ASSEMBLIES → COMPONENTS → 
ADD COMPONENT 

 
The dialogue box on the right side will pop up. You can 
select the part files from those existing or else you can 
load the part files using the OPEN file options in the 
dialog box. This will load the selected part file into the 
LOADED PARTS dialog box. 
 

� Click on the file Impeller_upper-casing.prt  
 

� Click OK in the part name dialog box 
 

You will see that a small copy of the component object 
appears in a separate window on the screen as shown in 
the figure below. 

 

 

You will need to place this figure initially at certain location. This can be done by changing the 

Positioning option in the PLACEMENT dialog box to Absolute Origin as shown. 
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� Click OK 
 

You will see the object on the screen as follows: 
 

 
 
Now we will add the second component, the lower casing.  
 

� Click on ASSEMBLIES →→→→ COMPONENTS →→→→ ADD COMPONENT 

 
� Select the file Impeller_lower-casing.prt  
 
� In the POISTIONING dialog box change the 

option to By Constraints  
 
� Choose APPLY 
 
This will show you the added component in a 
COMPONENT PREVIEW window as before. 
 
Now let us mate the upper and the lower casing. 
Unlike NX5 where Mate command used to make 
the two objects touch each other to make them 
coplanar, in NX7 we have the Touch/Align 
command. You can access all the constraints in the 
drop-down menu in the Type dialog box in the 
ASSEMBLY CONSTRAINTS menu.  
 
The following dialog box will appear. 
 
Here you can see the different Mating Types, which were explained above in section 8.4. 
 
Now let us give the Mate constraint. 
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� Make sure the Touch Align icon  is selected in the TYPE dialog box  
 

� First, select the face that the arrow is pointing to in the Component Preview window as 
shown below in the figure on the left figure below. 

 

� Click on the face of the Upper Casing in the main screen as shown in the figure on the right. 
You may have to rotate the figure in order to select the faces.  

 

   

The two assembled components will be seen as shown in the figure below. 
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The lower casing is constrained with respect to the upper casing. Now let us add the impeller.  

 
� Choose ASSEMBLIES → COMPONENTS → ADD COMPONENT 
 
� Open the file Impeller_impeller.prt  

  
� Click OK on the dialog box 
 
We will apply the Distance constraint. 
 
� Click on the Distance icon in the TYPE dialog box  
 
� Select the two faces, first on the impeller and then on the casing, as shown in the figure 

below   
 

� Click OK 
 
� In the Distance dialog box in the Assembly Constraints window, enter a value of 3 
 

 
 
� On the Assembly Constraints window, unclick the Preview Window option 
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The preview will show the impeller oriented in the direction opposite to the one we want. 

 

� On the Assembly Constraints window, click on 
the Cycle Last Constraint option in the Geometry 
to Constrain as shown in the figure on right 

 

Now the impeller will be oriented in the right direction.  

 

 

Now we will apply the Center constraint to the model. Save the assembly file. We will now add 

the shaft.  

� Click on ASSEMBLIES → COMPONENTS → ADD COMPONENT 
 

� Open the file Impeller_shaft.prt  
 

� Click OK on the dialog box 
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� Choose the Center icon  
 

� Choose the Infer Center/Axis option in the 
Geometry to Constrain dialog box in the Assembly 
Constraints window as shown in the figure on right 

 

� Select the two surfaces, first on the shaft in the 
preview window and then on the impeller on the 
main screen as shown in the figures below  

 
 

 

 

 

     

 

� Choose the Touch Align constraint  
 
� First, select the face on the shaft and then select the bottom face of the hole in the impeller as 

shown.  
 

� Choose APPLY and then click OK 
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The assembly will now look like the figure below. 

 

� Click on ASSEMBLIES →→→→ COMPONENTS →→→→ ADD COMPONENT 
 

� Open the file Impeller_hexa-bolt.prt 
 

� Choose the Touch Align constraint. Use the Infer Center/Axis option in the Geometry to 

Constrain dialog box 
 

� First, select the outer cylindrical threading on the bolt and then select the inner surface of the 
hole on the upper casing as show in the figures below. 
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� Again in the Touch Align constraint change the Geometry to Constrain option to Prefer 

Touch 

 
� Select the flat face on the bolt and the face on the rib of the upper casing as shown 
  
� Click APPLY and then OK  
 

 
 
 
The assembly is shown below.  
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� Repeat the same procedure as before to add the part file Impeller_washer.prt 
 

� Choose the Touch Align constraint. Use the Infer Center/Axis option in the Geometry to 

Constrain dialog box 
 

� Select the inner face of the washer and the cylindrical threading on the bolt as shown 
 

  

 
 
� Again in the Touch Align constraint change the Geometry to Constrain option to Prefer 

Touch 

 
� Select the flat face of the washer and then the face on the rib of the lower casing as shown 
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� Click APPLY and then OK 
 

   
 
The Assembly is shown below. 
 

 
 

� Add the part file Impeller_hexa-nut.prt in the same way as we attached the bolt and the 
washer.  
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� Repeat the same procedure to add bolts, washers, and nuts to all the holes in the casing. This 
completes the assembly of the impeller 

 

There is a simpler way to assemble the bolt, washer, and nut set. Instead of adding the three parts 

individually, you can assemble these components separately in another file. This will be a sub-

assembly. You can insert this subassembly and mate it with the main assembly.  

The Final Assembly will look as the shown below. Save the Model.  
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8.7 EXPLODED VIEW OF IMPELLER ASSEMBLY 
 

In this section, we are going to create an Exploded view of the Assembly to show a separated 

part-by-part picture of the components that make the assembly. In today’s industrial practice, 

these kind of views are very helpful on the assembly shop floor to get a good idea of which item 

fixes where. The user should understand that exploding an assembly does not mean relocation of 

the components, but only viewing the models in the form of disassembly. You can ‘Unexplode’ 

the view at any time you want to regain the original assembly view. Let us explode the Impeller 

Assembly.  

� Choose ASSEMBLIES → EXPLODED 
VIEWS → NEW EXPLOSION 

 

This will pop a Dialog box asking for the name of 

the Explosion view to be created. You can leave 

name as the default name and choose OK 

Now the UG environment is in Exploded view environment though you do not find any 

difference. When we start exploding some assembly, we should decide upon a component to 

keep that component as the reference. This component should not be moved from its original 

position. In the case of the impeller assembly, the impeller will be the right option as it is central 

to the entire assembly. Now let’s start exploding the components. 

� Right Click on the Upper casing and choose EDIT EXPLOSION 
 

The Edit Explosion window will pop up along with a Coordinate system on the component.  

 

� Click on the Z axis; hold the mouse and drag upwards until the reading in the Distance 
shows 20 as shown in the following figure. 
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� Choose OK 

 

� Right click on the Lower casing and choose EDIT EXPLOSION 
 

Again, this will pop up a Dialog window for Edit Explosion and a Coordinate system on the 

component. 

� Click on the Z-axis; hold the mouse and drag downwards until the reading in the Distance 
shows -20 as shown in the following figure. Choose OK 
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� Right click on the shaft and choose EDIT EXPLOSION. 
 

� This time click on the X-axis; hold the button and drag to the right side until the reading in 
the distance shows -25 as shown in the following figure 

 

�  Choose OK 
 

 

� Select all the six hexagonal bolts in the assembly by clicking on them 
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� Right click on one of them and choose EDIT EXPLOSION 
 

� This time click on the Z-axis; hold the button and drag upwards until the reading in the 
Distance shows 25 as shown in the following figure. This will move all the six bolts together 
to the same distance.  

 

� Choose OK 
 

 

Likewise, select all the six hexagonal nuts together and move them downwards to a value of -30 
and the six washers to the distance of -27. This is the Exploded view of the assembly. The 
following are the pictures of the Final Exploded view. You can rotate and see how it looks like.  
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It you want to retain the original assembly view you can unexplode any particular component,  

� Right click on the component and choose UNEXPLODE. 
 

If you want to unexplode all the components, 

� Choose ASSEMBLIES → EXPLODED VIEWS → UNEXPLODE COMPONENT 
 

Select all the components and choose OK. 

 

8.7 EXERCISE - ARBOR PRESS ASSEMBLY 
 

In this tutorial, we have modeled various parts, some of which are components of the arbor press, 

which is shown below. Assemble the arbor press using the components that you have modeled in 

addition to ones that are provided to you that you have not modeled before. The complete list of 

parts that the arbor press assembly consists of includes: 
 

• Allen Bolt 

• Allen Nut 

• Base 

• Circle base 

• End clip 

• Handle 
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• Hexagonal Bolt 

• L-bar 

• Pin 

• Pinion 

• Pinion handle 

• Plate 

• Rack 

• Sleeve 
 
All these parts are provided in a folder that can be accessed along with this tutorial in the same 
internet address. 
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All these parts are provided in a folder that can be accessed along with this tutorial in the same 
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All these parts are provided in a folder that can be accessed along with this tutorial in the same 
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CHAPTER 9 - FINITE ELEMENT ANALYSIS 
 

FEA, or Finite Element Analysis, is a technique for predicting the response of structures and 

materials to environmental factors such as forces, heat and vibration. The process starts with the 

creation of a geometric model. The model is then subdivided (meshed) into small pieces 

(elements) of simple geometric shapes connected at specific node points. In this manner, the 

stress-strain relationships are more easily approximated. Finally, the material behavior and the 

boundary conditions are applied to each element. Software such as NX7 computerizes the 

process and makes it possible to solve complex calculations a matter of minutes. It can provide 

the engineer with deep insights regarding the behavior of objects.  

 

Some of the applications of FEA are Structural Analysis, Thermal Analysis, Fluid Flow 

Dynamics, and Electromagnetic Compatibility. Of these, FEA is most commonly used in 

structural and solid mechanics applications for calculating stresses and displacements. These are 

often critical to the performance of the hardware and can be used to predict failures. NX7 has an 

NASTRAN solver to perform the FEA. NX7 offers two modules for FEA i.e, Advanced 

Simulation and Design Simulation. Advanced Simulation can be used to perform Thermal 

analysis, Flow simulation and can also be used to analyze Electronic and Space systems. It has 

more options for geometry idealization and also provides 1D and 2D mesh generation options 

along with 3D mesh, which is the only option in Design Simulation module. Design Simulation 

is generally used for structural analysis. In this chapter, we are going to deal with the structural 

stress and strain analysis of solid geometries.  

 

9.1 INTRODUCTION  
 

9.1.1 Element shapes and nodes 
 

The elements can be classified into different types based on the number of dimensions and the 

number of nodes in the element. The following are some of the types of elements used for 

discretization.  

One-dimensional elements: 
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Two-dimensional elements: 

Triangular: 

 

Quadrilateral: 

 

Three-dimensional elements: 

Tetrahedral (a solid with 4 triangular faces): 

 

Hexahedral (a solid with 6 quadrilateral faces): 
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Types of nodes: 

                                         Corner nodes 

            Exterior nodes 

Side nodes               

Interior nodes    

The results of FEA should converge to the exact solution as the size of finite element becomes 

smaller and smaller.  

9.1.2 Structure Module 
 

� Copy and paste the file Impeller_impeller.prt into a new folder to avoid changes being 
made to the assembly 
 

� Open this newly copied file 

 

� Click on START → ALL APPLICATIONS → DESIGN SIMULATION  
 

The following figure is the toolbar for Finite Element Modeling and Analysis of Structures. 

 

 Solution: Clicking on this icon will open up the CREATE SOLUTION window where 

you can select the solver algorithm from one of these: NX NASTRAN, MSC NASTRAN, 

ANSYS or ABAQUS. In addition, you can choose the type of analysis to be performed.  In this 

tutorial, only Structural Analysis will be covered with NX NASTRAN.  
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 Material Properties: This allows you to change the physical properties of the material that 

will be used for the model. For example, if we use steel to manufacture the impeller, we can 

enter the constants such as density, Poisson’s ratio, etc. These material properties can also be 

saved in the library for future use or can be retrieved from Library of Materials available in NX7.  

 Loads: This option allows you to exert different types of forces and pressures to act on the 

solid along with the directions and magnitudes.  

 Boundary Conditions: Boundary conditions are surfaces that are fixed to arrest the degrees 

of freedom. Some surfaces can be rotationally fixed and some can be constrained from 

translational movement. 

 3D Tetrahedral Meshes: This icon is one of the mesh options that can be used to discretize 

the model as discussed in beginning of the chapter. Normally, we select tetrahedral shapes of 

elements for approximation. You can still select the 2-D and 1-D elements depending on the 

situation and requirements by choosing these options from the drop-down menu.  

 Solve: This is the command to solve all the governing equations by the algorithm that you 

choose and all the above options. This solves and gives the result of the analysis of the scenario.  

 

9.1.3 Simulation Navigator 
 

The Simulation Navigator provides the capability to 

activate existing solutions, create new ones, and use 

the created solution to build mechanisms by creating 

and modifying motion objects. To display the 

Simulation Navigator, click the Simulation 

Navigator tab in the Resource bar as shown in the 

figure. 

 

It shows the list of the scenarios created for the master 

model file. In each scenario, it displays the list of 

loads, boundary conditions, types of meshes, results, 

reports generated and so on.  
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9.2 SOLUTION CREATION 
 

The DESIGN SIMULATION module is in a way different from when the first scenario is 

created. NX7 creates a folder of the same name as that of the file and at the same location where 

the file is located. For every scenario or Solution, it creates five different files with the name of 

the scenario. They are xxx.SIM, xxx.DAT, xxx.txt, xxx.out and xxx.VDM. All the results 

generated for the scenarios are saved as .vdm files. You can think of a scenario model as a 

variation of a master design model. Scenarios contain all the geometric features of the master 

model. They also support body promotions and interpart expressions.  

Body promotions are used to provide an independently modifiable copy of the master model 

geometry and serve as a place to hold scenario-specific features such as mid-surfaces.  

The scenario model's geometry is linked to the master 

model geometry, but a scenario may have additional 

unique information. For example, the master model may 

contain all the information about the model's geometry, 

but the scenario model will contain additional motion 

data, such as information about links and joints.  

Now we will create a scenario. Note: When you first 

open any file in Design Simulation module, it will 

automatically pop up with Solution creation window to 

create a solution.  

� Click on the Simulation Navigator icon on the 

navigator toolbar  
 

� Right-click on Impeller_impeller and choose New 
FEM And Simulation 

 

 

This will pop up the New FEM and Simulation dialog 

box to create a new scenario. 

� Click OK 
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This pops up another window that creates different scenarios as shown below 

 

 

 

 

 

 

 

In the Create Solution window, you can select the Solver and the Solution Type.  

� Enter the Name of the first scenario as Analysis_1  
 

The default Solver type is NX NSATRAN DESIGN and Analysis type as STRUCTURAL.   

� Choose OK to create a new Solution called Analysis_1, which is displayed in the 
Simulation Navigator 

 

The Simulation Navigator will now look like the following figure. 
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9.2.1 Material Properties 
 

The next step is to give the material properties to the solid model for this scenario. Because we 

don’t have any data in the library to retrieve for standard material, we will create one. Let us 

assume that we will use steel to manufacture the impeller. 

Click on the Material Properties icon on the Toolbar  

 

The Materials window will pop up. You have the option of choosing the pre-defined materials 

from the library or create another material. 
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Enter the name and values as shown in the following figure. Pay attention to the units.   
      (Note that 30e6 represents 30X106) 

� Choose OK to exit the Isotropic Material window 
 

� Click on the Impeller model 
 

� Click Apply and then OK 
 

 

This will assign the material properties to the impeller. The next step is to mesh the model. 
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9.2.2 Mesh 
 

The ‘Mesh’ option discritizes the model into small elements. The model has to be meshed before 

applying the boundary conditions and loads in the process of FEA.  

� Click on the 3D Tetrahedral Mesh icon  
 

A window will pop up asking for the type and size of the elements. 

� Click on the solid object model on the graphic screen 
 

 

  

There are two types of tetrahedral elements available in Design Simulation module of NX7. One 

is 4-nodes and another is 10-node.  

� Choose the Type to be TETRA10 
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� Enter the Overall Element Size as 1.0 
 

� Choose OK 
 

You can find the Solid model with small tetrahedral elements. It will look like the figure shown 

below. 

 

 

 

Note: While meshing the solid there is a trade-off you need to consider. If you choose a smaller 

element with higher nodes you will get better accuracy in your analysis than larger element. 

However, the time required to solve the model with smaller elements will much greater than with 

larger element. Hence, based on the accuracy requirement of the study and how critical the 

component is in terms of the end product choose the appropriate size of the elements and nodes. 
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9.2.3 Boundary Conditions 
 

Let us give the boundary conditions for this scenario. The 

impeller rotates about the axis of the cone with the shaft as you 

can see in the assembly in the previous chapters. It is not fixed. 

But our concern is the deformation of the blades with respect to 

the core of the impeller. The conical core is relatively fixed and 

the deformations of the blades are to be analyzed accordingly. 

 

� Click on the Constraint Type icon   

 

� Select the Fixed Constraint  
 

This type of constraint will restrict the selected entity in six DOF from translating and rotating. 

You can see the different constraints available by clicking the Constraint drop-down menu on the 

toolbar. 

� Click on the meshed conical surface of the impeller as shown in the following figure 
 

 
 

 

� Choose OK 
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9.2.4 Loads 
 

The loads applied on the meshed model should be input to the system. For the impeller, the 

major force acts on the concave surfaces of the turbine blades. This loading can be approximated 

by normal pressure on all the five surfaces. Since we are not too concerned about the magnitude 

of the load, let us take the value to be 100 lbf/sq inch to exaggerate the deformation of the 

blades. 

� Click on the Loads icon  
 

� Click on the five concave surfaces of the blades as shown in the 
following figures 

 

       

 

 

� Enter the value for Pressure as 100 and keep the units as lb-f/in2 (psi) 
 

� Choose OK 
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9.3 RESULT AND SIMULATION 
 

9.3.1 Solving the Scenario 
 

The Finite Element Model is now ready for solving and analysis. It is a good practice to first 

check for model completion before we get into solving the model. To check the model 

 

� Click on the Check icon on the 
Toolbar  

 

This will pop-up a menu as shown on the right.  

� Choose OK 
 

This will display the result of the Check. You will be able 

to see any errors and warnings in a separate window. The 

errors or warnings in the FEA model creation are; no 

material, no loads and so on. In case you get these errors or warnings go back to the previous 

steps and complete the required things. 

 

If you do not get errors or warnings you are ready to 

solve the FEA problem. 

 

� Click on the Solve icon   
 

This will open the Solve window.  
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� Click OK without making any changes 
 

Note: In case of any error messages while solving, the solver can be manually specified by 

clicking on the “Edit Solver Parameters” link in the solve window. This generally happens when 

there are multiple solvers installed or if the previous version of NX is not uninstalled properly. 

The following procedure needs to be followed in this case: 

Edit Solver Parameters � Uncheck “use environmental variable UGII_NX_NASTRAN” in 

solver executable � user defined � select the solver manually at the following location 

C:\Program Files\UGS\NX 7.5\NXNASTRAN\bin\nast7.exe  � Click OK 

 

It may take a while to generate the results. Wait until the Analysis Job Monitor window 

appears, showing the job to be Completed. While the solver is doing computations, the Analysis 

Job Monitor will show as Running 

 

 

 

 

 

 

 

 

 

� Click on CANCEL when the Analysis Job Monitor window says Completed 
 

9.3.2 FEA Results 
 

� Open the Simulation Navigator 
 

� Double-click on RESULTS to see the analysis results 
 

 
This will take you into the Post-Processing Navigator. The Post-Processing Navigator shows all 

the Solution you created. If you click the ‘+’ sign in front of the Solution you will see the 

different analyses that have been performed on the model. 
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� Double-click on the Displacement-Nodal menu 
 

The screen will now appear as shown below.  

 

 

You can easily interpret the results from the color-coding. The orange-red color shows the 

maximum deformation zones and the blue area shows the minimum deformation zones. You can 

observe that because the conical core is fixed, it experiences zero deformation. The analysis also 

shows that the maximum deformation experienced at the tip of the 

blades is 1.68 x 10-3 inches. 

On the Post-Processing Navigator, you can keep changing the 

results by double clicking each option as shown below. You can 

click on the other inactive marks to see various results.  
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Some of the other results are shown below. 

       

 

9.3.3 Simulation and Animation 
 

The Post Processing Toolbar should appear when you select the Design Simulation Module. 

However, in case it does not become visible follow these steps. 

� Right click anywhere in the empty space in front of the Design Simulation toolbar and you 
will get a list of toolbar options available. Click on the Post-Processing Toolbar option. You 
will get the following toolbar 

 

 

� Click on the Animation icon on the Post Processing Toolbar  
 

� In the Animation Setup window, change the number of frames to 10 and click on the Play 

button  to see the animation of the deformation 
 

You can also find the play button on the Post Processing Toolbar itself. 
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You can now see an animation of how the impeller is deformed as the loads are applied to the 

blades.  

� To make any setting changes in the results display, click on the Post View icon as shown in 
figure below  

 

� In the popped up Post View Dialog box click on Deformed Results under DISPLAY tab 
button  

 

� In the Deformed Results dialog box check the Show Un-deformed Model as shown in the 
second figure below and choose OK 
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Now press on the Play button to see the animation. This will show the animation of deformation 

with the original shape in Grey color, as shown in the figure below.  

 

 

� Click on the Stop button 
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� Right-click on the Analysis_1 in the Post-Processing bar and click on Unload. This should 
take your screen back to the meshed model 

There are two ways to improve the accuracy of FEA results. 

• Reduce the size of element 

• Increase the order of interpolation polynomial (i.e. use 
quadratic or even cubic instead of linear polynomials) 

 

The second approach is preferred because it is more efficient 

in terms of computation time and takes less memory space. 

However, let us try to create a scenario using the first option.   

� Right-click on Analysis_1 in the Simulation Navigator 
 

� Choose CLONE to copy the first scenario 
 

� Choose OK on the Message box 
 

� Once Copy of Analysis_1 is created, rename it to 
Analysis_2 

 
� Right click on the 3D Mesh (1) and click Edit 
 

� In the dialog box shown, change the Type to TETRA4 
 

� Choose OK 

� Click on the Solve icon  to solve the scenario  
 

� Click OK 
 

The Analysis Job Monitor should show the status of 

Analysis_2 to be Completed. 

� Click CANCEL  
 

� In the Simulation Navigator, double-click on Results 
for Analysis_2 
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The figure below shows the analysis. You can observe the change in the maximum deviation. 

Save all the scenarios and close the files.  

 

 

9.4 EXERCISE - ARBORPRESS L-BAR 
 

Open the file ‘Arborpress_L-bar.prt’ and do a similar structure analysis, considering the 

material as steel. For the mesh, the element size should be 10.00 and the type Tetra10.  

For the loads, apply a normal pressure with a magnitude of 500 on the top surface as shown in 

the figure below. 
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For the boundary conditions, fix the three flat faces (the front highlighted face, the face parallel 

to it at the backside and the bottom face) as marked in the following figure. 
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CHAPTER 10 - MANUFACTURING 
 

As we discussed in Chapter 1 about the product realization process, the models and drawings 

created by the designer have to undergo other processes to get to the finished product. This being 

the essence of CAD/CAM integration, the most widely and commonly used technique is to 

generate program codes for CNC machines to mill the part. This technological development 

reduces the amount of human intervention in creating CNC codes. This also facilitates the 

designers to create complex systems. In this chapter, we will cover the Manufacturing Module of 

NX7 to generate CNC codes for 3-Axis Vertical Machining Centers. The manufacturing module 

allows you to program and do some post-processing on drilling, milling, turning and wire-cut 

EDM tool paths. 

 

10.1 GETTING STARTED WITH MANUFACTURING MODULE 
 

A few preparatory steps need to be performed on every CAD model before moving it into the 

CAM environment. Throughout this chapter, we are going to work with one of the models that 

were given in the exercise problems. For a change, all the units are followed in millimeters in 

this model and manufacturing of the component. 

Before getting started, it would be helpful if you 

can get into a CAM Express Role. To do this, go 

to the Roles menu on the Resource Bar and click 

on the INDUSTRY SPECIFIC tab. A drop-

down menu will pop up in which the CAM 

Express role can be seen as shown in the figure. 
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10.1.1 Creation of a Blank 
 

After completing the modeling, you should decide upon the raw material shape and size that 

needs to be loaded on the machine for the actual machining. This data has to be input in NX7. 

This can be achieved in two ways. The first method is by creating or importing the model of the 

raw material as a separate solid in the same file and assigning that solid as the Blank. The 

second method is by letting the software decide the extreme dimensions of the designed part and 

some offset values if wanted. The later method allows a quick way of assigning the raw size 

details but it can only be used for prismatic shapes.  

� Open the file ‘Die_cavity.prt’ of the exercise problem in Chapter 6 
 

� Click on  START  → MODELING  
 

� INSERT a block with the following dimensions and positioning. 
Length = 150 mm 
Width = 100 mm 
Height = 80 mm 

� In the Point Constructor icon located on the toolbar as shown position the block at the point 
(-75, -50, -80).  

 

  

This block encloses the entire design part so we will change the display properties of the block.  
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� Click on the EDIT OBJECT DIPLAY icon on the 
toolbar as shown. 

 

 

Two features, labeled as BLOCK, show up in the 

QUICKPICK menu, one for the design part and one for the 

block.  

� Move your mouse on the labels to see which one 
represents the block you created just now. 
 

� Select the block you created 
 

� Click OK 
 

� When the window pops up, change the display color and 
change the Translucency to 50 

 

� Then click OK 

 

Hide the block you just created by right clicking on the block in the Part Navigator. This will 

make the raw block disappear from the environment. Whenever you want to view or work on 

this solid, reverse the blanks. This is done by pressing <Ctrl> + <Shift> + B.  

 

10.1.2 Setting Machining Environment 
 

Now we are set to get into the Manufacturing module.  

� Select  START → MANUFACTURING 
 

A window will pop up asking for the Machining Environment 

Setup. There are many different customized CAM sessions 

available for different machining operations. Here, we are only 

interested in the Milling operation. 

� For CAM Session Configuration, select cam_general and for 
CAM Setup, select mill_contour. This window pops up when you start the Manufacturing 
Application 
 

� Click OK 
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10.1.3 Operation Navigator 
 

As soon as you get into the Manufacturing environment, you will notice many changes in the 

main screen such as new icons that are displayed.  

� Click on the OPERATION NAVIGATOR tab on the right on the RESOURCE BAR 
 

The Operation Navigator gives information about the programs created and corresponding 

information about the cutters, methods, and strategies.  

 

 

 

 

 

 

 

The list of programs can be viewed in different categorical lists. There are four ways of viewing 

the list of programs in the Operation Navigator. The four views are Program Order view, 

Machine Tool view, Geometry view and Machining Method view. If you want to view the list of 

programs under different cutter tools, you can do so by clicking the particular icon in the 

Manufacturing Toolbar at top of the graphic screen.  
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10.1.4 Machine Coordinate System (MCS)  
 

� Click on the Geometry View icon in the toolbar to 
initiate setup for programming 

 

 

 

You will see a Create Geometry pop-up. 

You should be able to see the Mill_MCS as the program 

name in the Operation Navigator. If you do not see it, click 

on the Geometry View button in the Toolbar again. 

� Click OK 
 

Another pop-up window will allow you to set the MCS 

wherever, you want. By default NX7 takes the original WCS 

as the MCS. 

� Click on the button shown. This will highlight the default 
WCS of the part and assign it as the MCS 

 

� Click OK to select it as the MCS 
 

� Click OK when you are done orienting and positioning 
the MCS 
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10.1.5 Geometry Definition 
 

� Double-click on WORKPIECE in the Operation 
Navigator. If you don’t see it, click on the plus sign next 
to MCS_MILL 
 

The pop up window MILL GEOM appears. This is where you 

can assign the part geometry, blank geometry, and check 

geometry if any.  

� Click on the Part icon 
 

� Select the design part and click OK 
 

Now we have to select the Blank Geometry.  

� Click the Blank icon  
 

This will open the Blank Geometry Window. As mentioned earlier there are many ways to 

assign the blank. You can use a solid geometry as the Blank or can allow the software to assign a 

prismatic block with desired offsets in the X, Y, and Z directions. As we have already created a 

Rectangular Solid we can use that as the Blank geometry. 

Remember that our block is hidden.  

� Retrieve the block by pressing <Ctrl> + <Shift> + B 
 

� In the Blank Geometry window, make sure the 
Geometry radio button is selected 

 

� Select the block and click OK 
 

� Bring the part geometry back by pressing <Ctrl> + 
<Shift> + B once again  

 

� Click OK on the MILL_GEOM dialog box 
 

Now we are finished assigning the Part and Blank geometries. Sometimes it may be required to 

assign Check geometry. This option is more useful for shapes that are more complex or 5-Axes 

Milling operations where the Tool cutters have a higher chance of dashing with the fixtures. In 

our case, it is not very important to assign a Check Geometry.  
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10.2 CREATING OPERATION AND PARAMETER SETTING 
 

10.2.1 Creating a new Operation 
 

The Manufacturing setup is now ready for us to work further with Programming Strategies. 

There are many different manufacturing strategies involved in programming and it takes practice 

to know which one is the most efficient. Here, the basic guidelines are given for the most widely 

and frequently used strategies. The chapter will also cover important parameters that are to be set 

for the programs to function properly.  

� Click on the Create Operation icon in the toolbar as shown 
 

The Create Operation window will pop up. 

� Make sure the Type of Operation is mill_contour 
There are many different subtypes under Mill-Contour, namely Cavity Mill, Z-Level Follow 

Cavity, Follow Core, Fixed Contour, and so on. These different subtypes are used for different 

situations and profiles of the design part. As mentioned before, how you select a strategy for any 

situation depends on your experience.  

� Click on the CAVITY_MILL icon at the top left as shown in the figure 
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� Change the Program from NC_PROGRAM to 
PROGRAM 
 

� Change the Use Geometry to WORKPIECE 
 

� The program takes the default name CAVITY_MILL 
 

� Click OK 
          

The program parameters window with CAVITY_MILL in 

the title bar will pop up. On this window, you can set all 

the parameters for the program. A brief introduction on 

every important parameter and terminology will be given 

as we go through the sequence.  

 

10.2.3 Tool Creation and Selection 
 

One of the most important decisions to make is to select 
the right shape and size of the tool to use. Before starting 
with the Tool parameter settings, we must first know 
about the types of Tool cutters. The Milling tool cutters are categorized into three forms of 
cutters. Hence, when selecting a cutter, it is important to take into consideration the size, shape, 
and profiles of the design parts. For example, if the corner radius of a pocket is 5 mm, the pocket 
should be finished by a cutter with diameter less than or equal to 10 mm. Otherwise it will leave 
material at the corners. There are other special forms of cutters available in markets that are 
manufactured to suit this need. 

Flat End Mill Cutters:  

These cutters have a sharp tip at the end of the cutter as shown in the figure. These cutters are 
used for finishing parts that have flat vertical walls with sharp edges at the intersection of the 
floors and walls.  

   

Ball End Mill:  

These cutters have the corner radii exactly equal to half the diameter of the shank. This forms the 
ball shaped profile at the end. These cutters are used for roughing and finishing operations of 
parts or surfaces with freeform features. 
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Bull Nose Cutters:  

These cutters have small corner radii and are widely used for roughing and/or semi-finishing the 
parts as well as for finishing of inclined and tapered walls. 

   

The cutter that we are going to use to rough out this 
huge volume is BUEM12X1 (Bullnose End Mill with 
12 diameter and 1 corner radius).  

� In the CAVITY_MILL pop-up menu click on the 
Create New button in the TOOL, dialog box 

 

� Click NEW 
 

� On the New Tool window, select the Mill icon 
 

� Type in BUEM12X1 as the Name and click OK 
 

This will open another window to enter the cutter 
dimensions and parameters. You can also customize the 
list of tools that you would normally use and call the 
cutters from the library.  

� Enter the values as shown in the figure below.  

  

  

 

 

 

 

 

 

 

 

� Click OK 
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� In the CAVITY_MILL menu click on the Path Settings option 
 

10.2.4 Tool Path Settings 
 

There are different options in which the tool can move. The following is a description of each. 

 

 Zig-Zag:  This tool takes a zigzag path at every level of depth. It saves time by reducing 

amount of air cutting time (idle running). The climb and conventional cuts alternate.  

 Zig: This takes a linear path in only one direction of flow.   

 Zig with Contour: This takes the path in one direction either climb or conventional. The 

unique thing is that it moves along the contour shape nonlinearly.  

 Follow Periphery: This takes the path depending upon the periphery profile. For example, 

the outer periphery of our part is rectangular. So the tool path will be generated such that it 

gradually cuts the material from outside to inside with the Stepover value. This option is mostly 

used for projections and cores rather than cavities. 

 Follow Part: This is the most optimal strategy where the tool path is manipulated 

depending on the part geometry. If there are cores and cavities in the part, the computer 

intelligently considers them to remove the materials in an optimal way. This is widely used for 

roughing operations.  
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Trochoidal: This cutter is huge and is used for removing a large amount of material. The 

bulk of material is removed by gradual trochoidal movements. The depth of cut used will be very 

high for this strategy.   

 Profile: This takes the cut only along the profile of the part geometry. It is used for semi-

finishing or finishing operations.  

� For this exercise, select the Follow Part icon from the Cut Pattern drop-down menu since 
we have both projections and cavities in our part.  

 

10.2.4 Step Over and Scallop Height:  
 

Step Over: 

This is the distance between the consecutive passes of 
milling. It can be given as a fixed value or the value in 
terms of cutter diameter. The step-over should not be 
greater than the effective diameter of the cutter 
otherwise; it will leave extra material at every level of cut 
and result in an incomplete milling operation. The 
numeric value or values required to define the step-over 
will vary depending on the step-over option selected. 
These options include Constant, Scallop, Tool Diameter, 
etc. For example, Constant requires you to enter a 
distance value in the subsequent line.  

Scallop Height:  

Scallop Height controls the distance between parallel passes according to the maximum height of 
material (scallop) you specify to be left between passes. This is affected by the cutter definition 
and the curvature of the surface. Scallop allows the system to determine the Stepover distance 
based on the scallop height you enter. 

 

 

 

� For the Step-over, select TOOL FLAT and change the Percent to 70.  
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10.2.5 Depth per cut 
 

This is the value to be given between levels to slice 
the geometry into layers and the tool path cuts as per 
the geometry at every layer. The cut depth value can 
vary for each level. Levels are horizontal planes 
parallel to the XY plane. If we do not give cut levels, 
the software will unnecessarily try to calculate slices 
for the entire part and machine areas that are not in 
our interest.  

 

� Change the Common Depth per Cut value to be 0.5 
 

Now we will add the level ranges. This will split the part 
into different levels along the Z-direction to be 
machined. 

 

� Click on CUT LEVELS as shown below 
 

This will pop up a Dialog box for Cut Levels. You need 
to set the level of the cut. You can either point to the 
object till which the cut level is or provide it as Range 
Depth value (0-100). We are not going to mill up to the 
bottommost face of the Part, but up to the floor at 40mm 
from top. Therefore, we must delete the last level.  

 

� Use the up and down scroll buttons until you reach 
the level that has a Range Depth of 80 
 

� Select OK after making these adjustments 
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10.2.6 Cutting Parameters 
 

� On the parameters window, click CUTTING 
PARAMETERS 

 

This pops up another dialog box. 

� Under the ‘Strategy’ tab button, change the Cut Order 
from Level First to DEPTH FIRST 

 

 

 

Changing the cut order to Depth First orders the software to generate the tool path such that it 

will mill one island completely up to the bottom-most depth before jumping to another level. The 

Depth First strategy reduces the non-cutting time of the program due to unnecessary retracts and 

engages at every depth of cut.  

� Click on the Stock tab 
 

� Change the value of the Part Side Stock to 0.5 
 

This value is the allowance given to every side of the part. If you want to give different values to 

the floors (or the flat horizontal faces) uncheck the box next to ‘Use Floor Same As Side’ and 

enter a different value for Part Floor Stock.  

� Choose OK  
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10.2.7 Avoidance 
 

� Click the NON CUTTING MOVES   
 

� Click  the AVOIDANCE tab 
 

This window consists of many avoidance points like, Start Point, Go Home Point, etc. Of these, 

we are concerned with three points. They are as follows.  

From Point: 

This is the point at which the 
tool change command will be 
carried out. The value is 
normally 50 or 100 mm above 
the Z=0 level to enhance the 
safety of the job when the 
cutter is changed by the 
Automatic Tool Changer 
(ATC).  

� Click FROM POINT  
 

� Choose SPECIFY  
 

� In the Point Constructor, enter the coordinates of XC, YC and ZC as (0, 0, 50) 
 

� Choose OK 
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� Choose OK again to go back to the Avoidance window 
 

Start Point: 

This is the point at which the 

program starts and ends. This 

value is also 50 or 100 mm 

above the Z=0 level to enhance 

safety. It is also the point at 

which the machine operator 

checks the height of the tool 

mounted on the spindle with 

respect to the Z=0 level from the 

job. This cross checks the tool 

offset entered in the machine. 

� Click on START POINT 
 

� Choose SPECIFY  
 

� Enter the coordinates (0, 0, 50) in the Point Constructor 
 

� Click OK to exit the Point Constructor 
 

Clearance Plane: 

This is the plane, on which the tool cutter will retract before moving to the next region or island. 
This is also known as Retract Plane. Sometimes the Clearance Plane can be the previous 
cutting plane. However, when the tool has to move from one region to another, it is necessary to 
move to the clearance plane 
before doing so. The value of the 
clearance plane should be at least 
2 mm above the top most point of 
the workpiece or fixture or 
whichever is fixed to the machine 
bed.  

� Click on the 
TRANSFER/RAPID tab 

 

� Choose PLANE in the 
CLEARANCE OPTION 

 
� Choose the XY Plane from the drop-down menu in Type tab 
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� Under the Offset and Reference tab enter the value as 3 
in the Plane Constructor window 
 

� Click OK twice to go back to the CAVITY_MILL 
parameters window 

  

10.2.8 Speeds and Feeds 
 

Choose FEEDS AND SPEEDS to enter the feed and speed 

parameters 

Speed: 

Speed normally specifies the rpm of the spindle (spindle 
speed). However, technically the speed refers to the 
cutting speed of the tool (surface speed). It is the linear 
velocity of the cutting tip of the cutter. The relative 
parameters affecting this linear speed are rpm of the 
spindle and the diameter of the cutter (effective diameter).  

� Enter the Spindle Speed value as 4500 rpm 
 
For the Surface Speed and the Feed per Tooth, you should 
enter the recommended values given by the 
manufacturers of the cutter. By entering these values, 
the software will automatically calculate the cutting 
feed rate and spindle speed. You can also enter your 
own values for feed rates and spindle speeds.  

 

Feeds: 
There are many feeds involved in a single program. 
The most important is the Cutting feed. This is the 
feed at which, the tool will be in engagement with the 
raw work-piece and actually cutting the material off 
the work-piece. It is the relative linear velocity, at 
which the cutter moves with respect to the job.  

The other feeds are optional. Some machine control 
systems use their default retracts and traverse feed. In 
those cases, even if you do not enter the values of other 
feeds, there would not be any problems. Some control 
systems may look for these feed rates from the 
program. It can be slightly less than the machine’s 
maximum feed rate.  
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� For this exercise, enter the values as shown in the figure. Make sure to enter the Cut value as 
1200 mmpm. 
 

� Click OK  

 

10.3 PROGRAM GENERATION AND VERIFICATION 
 

10.3.1 Generating Program 
 

Now we are done entering all the parameters required for the roughing program. It is time to 
generate the program.  

� Click on the Generate icon at the bottom of the window  
 

 

You can now observe the software slicing the model into depths of cuts and creating tool-path at 
every level. You can find on the model cyan, blue, red and yellow lines as shown in the figure.  
 

 

 

 

 

 

 

 

During the generation, you will be prompted with a 
Display Parameters window.  

� Uncheck the box next to Pause After Each Path 
 

� Then click OK to see the display of cut-levels and tool paths 
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� After the generation is done, click OK in the parameters window  
 

10.3.2 Tool Path Display 
 

Whenever you want to view the entire tool-path of the program, right-click on the program in 

Operation Navigator and click Replay. It will give the display as shown in the Figure.  

 

You can now observe that next to the program in the Operation Navigator is a yellow 

exclamation point instead of a red mark. This means that program has been generated 

successfully but has not been post-processed. If any change is made in the model, the program 

will again have a red mark next to it. This implies that the program has to be generated again. 

However, there is no need to change any parameters in the program.  

 

10.3.3 Tool Path Simulation 
 

It is very important to check the programs you have created. This prevents any improper and 

dangerous motions from being made in the cutting path. It is possible that wrong parameters and 

settings will be given that cause costly damages to the work piece. To avoid such mistakes, NX7 

and other CAM software provide Tool-path verification and a Gouge check.  

Verify: 

The Tool-Path verification can be used to view the cutter motion in the entire program. You can 

observe how the tool is engaged and how it retracts after cutting. It also shows the actual material 

being removed through graphical simulation. You can also view the specific zone of interest by 

moving the line of the program.  
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� Right-click on the program in the Operation  Navigator and choose TOOL PATH → 
VERIFY or click on the Verify Tool Path button in the toolbar 

 

 

This will allow you to set the parameters for visualization 

of the Tool-Path. 

� On the Tool Path Visualization window, click on the 

Play icon  to view the Tool Path motion  
 

 

You can also view the visualization in different modes by 
changing the options in the drop-down menu next to 
Display.  

� Click on the 3D DYNAMIC tab on the same window 
 

� Click on the DISPLAY OPTIONS button on the 
same window  

 

� Change the Number of Motions to 50 
 

� Change the Animation Accuracy to FINE 
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� Change the IPW Color to Green 
 

� Click OK 

� Click on the Play button  again 
 

The simulation will look as shown in the figure 
below. 

With this option, you will be able to view the 
actual cutting simulation and material removal 
through computer graphics. This is 3D Dynamic, 
where you can rotate, pan and zoom the 
simulation when it is playing. The cutting 
simulation is 3D.  

Let us try the 2D Dynamic simulation. When this simulation is playing, you cannot do any other 
actions in NX7. Unlike 3D, you cannot rotate or zoom while playing. If you want to see the other 
side of the part, you have to stop the simulation, rotate and play again. This is faster than 3D 
Dynamic. 

  
10.3.4 Gouge Check 
 

Gouge Check is used to verify whether the tool is removing 
any excess material from the workpiece with respect to Part 
Geometry. Considering a Design Tolerance, any 
manufacturing process may produce defective parts by two 
ways. One is removing excess material, which is also called 
Less Material Condition. The other one is leaving materials 
that are supposed to be removed which is More Material 
Condition. In most cases, the former is more dangerous since 
it is impossible to rework the design part. The latter is safer 
since the leftover material can be removed by reworking the 
part. The gouge check option checks for the former case 
where the excess removal of material will be identified. 

� Right Click the program in the Operation Navigator  
 

� Choose TOOL PATH → GOUGE CHECK 

After the gouge check is completed, a message box will pop 
up saying “No gouged motions were found.” If in case there 
are any gouges found, it is necessary to correct the program.   

� Click OK on the message box 
 

� Close the pop-up window, which says that there are no gauge motions found. 
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10.4 OPERATION METHODS 
 

10.4.1 Roughing 
 

In case of milling operation, the first operation should be rough milling before finishing the job. 

The main purpose of roughing is to remove bulk material at a faster rate, without affecting the 

accuracy and finish of the job. Stock allowances are given to provide enough material for the 

finishing operation to get an accurate and good finish job. What we did in the earlier part of this 

chapter is generate a roughing program. Now we have to moderately remove all the uneven 

material left over from the previous program. 

10.4.2 Semi-Finishing 
 

Semi-Finishing programs are intended to remove the unevenness due to the roughing operation 

and keep even part stock allowance for the Finishing operations. Once we are done with the first 

roughing program, semi-finishing is always easier and simpler to perform.  

Now we will copy and paste the first program in the Operation Navigator. In the new program, 

you only have to change a few parameters and cutting tool dimensions and just regenerate the 

program.  

 

� Right-click CAVITY_MILL program in the 
Operation Navigator and click COPY  
 

� Right-click CAVITY_MILL again and choose 
PASTE 
 

� Right-click the second CAVITY_MILL_COPY 
you just made and click RENAME. Rename the 
second program CAVITY_MILL_1 

 

You can see that next to the newly created CAVITY_MILL_1 is a red mark, which indicates 

that the program is not generated.  

Cutter Selection: 

Let us now set the parameters that need to be changed for the second program. Before we even 

start, we should analyze the part Geometry to figure out the minimum corner radius for the cutter 

diameter. In our model, it is 5 mm and at the floor edges, it is 1 mm. Therefore, the cutter 

diameter can be anything less than 10 mm. For optimal output and rigidity, we will choose a Bull 

Nose Cutter with a diameter of 10 and a lower radius of 1.  

� Double-click CAVITY_MILL_1 on Operation Navigator to open the parameters window 
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Just as we did in the previous program, we have to create a 

new cutter. In the TOOL tab, you will see the cutter you first 

chose. It will show BUEM12X1 as the current tool.  

� Create a new cutter and name it BUEM10X1. It should 
have a diameter of 10 and a lower radius of 1 

 

� Click the Common Depth per Cut as 0.25 in the Path 
Settings tab.  

 
Then click on CUTTING PARAMETERS tab 

� Click on the STOCK tab button 
 

� Uncheck the box next to Use Floor Same As Side 
 

� Enter 0.25 for Part Side Stock 
 

� Enter 0.1 for Part Floor Stock 
 

 

 

 

 

 

 

� Click on the CONTAINMENT tab button 
 

� In the drop-down menu next to In Process Workpiece, choose USE 3D  



210 
NX7 for Engineering Design                                                                 Missouri University of Science and Technology 

 

 

In-Process Workpiece is a very useful option in NX7. The software considers the previous 
program and generates the current program such that there is no unnecessary cutting motion in 
the No-material zone. This strategy reduces the cutting time and air cutting motion drastically. 
The algorithm will force the cutter to only remove that material, which was left from the 
previous program and maintain the current part stock 
allowance.  

� Choose OK to return to the parameters window 
 

� Click FEEDS AND SPEEDS 
 

� Enter the Speed and Feed values as shown in the 
following figures 

 

� Then click OK 
    

The parameters and settings are finished for the semi-
finishing program.  

� Regenerate the program by clicking on the 

Generate icon  
 

� After the software finishes generating click OK 
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Then replay the Tool Path visualization. The overall Tool Path generated in the second program 

will look like the following figure. 

 

 

10.4.3 Finishing Profile 
 

So far, we are done with the roughing and semi-finishing programs for the part. There is a 

sufficient amount of material left in the Workpiece to be removed in the finishing programs to 

obtain the accurate part geometry as intended in the design. The finishing programs should be 

generated such that every surface in the part should be properly machined. Therefore, it is better 

to create more than one program to uniquely machine sets of surfaces with relevant cutting 

parameters and strategies rather than make one program for all the surfaces. The following 

illustrates how to group the profiles and surfaces and create the finishing programs.  

Outer Profile: 

This program is intended to finish the outer inclined walls onto the bottom of the floor. Because 

the program should not touch the contour surface on the top, we have to give Check and Trim 

boundaries in the program.  

� Repeat the same procedure as before to copy and 
paste CAVITY_MILL_1 on Operation Navigator 
 

� Rename the program CAVITY_MILL_2 
 

� Double click CAVITY_MILL_2 to make parameter changes 
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� In the pop-up parameters window, change the Cut Pattern to Profile and the Stepover 
percentage to 40 as shown in the figure 

 
� Click on the Specify Trim Boundaries tab 

 

The Trim Boundary window will pop up. Make sure to 

carry out the following procedure in the right sequence. Keep 

the default setting of TRIM SIDE to INSIDE. This tells the 

software that the cutter should not cut material anywhere 

inside the boundary. Trim allows you to specify boundaries 

that will further constrain the cut regions at each cut level. 

 

� Uncheck the Ignore Holes and check the box in front of 
Ignore Islands 

 

� Change Filter Type to CURVES 
 

� Change the Plane tab from Automatic to Manual 
 

A new window will pop up as shown below. The window 

will ask for the mode of selection of the plane on which the 

curves should be projected. This should normally be over the 

topmost point of the part geometry. Precisely, it should be 

over the MCS.  

� Choose the XC-YC Plane from the drop-down menu 
under Type 
 

� Enter a value of 3 next to it 
 

� Click OK 
 

Now we will start selecting edges from the part. These 

selected edges will be projected on the Z = 3 plane as curves 

and used as the boundary. 

 

� Select all the top outer edges on the wall along the contour 
surface as shown in the figure. Make sure to select all 8 
edges and in a continuous order 

 

� Choose OK 
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� Enter the Common Depth per Cut as 0.2 
 

� Click CUTTING PARAMETERS 
 

� In the pop up Dialog box, 
click on STOCK tab  
 

� Enter the Part Side Stock 
and Part Floor Stock 
values to be 0.00  

 

Intol: 

Intol allows you to specify the 

maximum distance that a cutter 

can deviate from the intended 

path into the workpiece. 

Outtol: 

Outtol allows you to specify the 

maximum distance that a cutter can deviate from the 

intended path away from the workpiece. 

� Enter the Intol and Outtol values to be 0.001 as 
shown in the figure 

 

� Click on CONTAINMENT tab and change the 
In-process Workpiece to NONE 

 

� Click OK 

� Click on the Generate icon  to generate the program in the Main Parameters window  

� Click OK on the parameters window when the program generation is completed 



214 
NX7 for Engineering Design                                                                 Missouri University of Science and Technology 

The finishing program for the outer profile is now ready. You can observe while replaying the 
tool path that the cutter never crosses the boundary that has been given for trim and check. The 
cutter retracts to the Z=3 plane for relocation. 

 

Inner profile: 

Repeat the same procedure as before to copy and paste 

CAVITY_MILL_2 on Operation Navigator and rename it as 

CAVITY_MILL_3.  

� Double-click CAVITY_MILL_3 to edit the parameters or 
right click on it and choose Edit 
 

� Select the Specify Trim Boundaries tab and choose Trim 

Side to be OUTSIDE in the pop up dialog box.  
 

This will prevent the cutter from passing outside the boundary. 

  

� Select the Filter Method to be CURVES 
 

� Change the plane manually to be the XC-YC plane and 

enter the offset distance as 3 
 

� Click OK 
 

� Select all the top inner edges along the contour surface as 
shown in the figure. Again, make sure all 8 edges are 
selected in a continuous order. 

 

� Then click OK 
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� Choose OK to return to the parameters window 
 

� Generate the program.  
 

� Click OK when the generation is finished.  
 

� Click on OK if you get any warning message about the tool fitting 
 

The finishing program for the outer profile is now ready. By replaying the tool path, you can 

observe that the cutter never crosses the boundary that has been given for trim and check.  
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10.4.4 Finishing Contour Surface 
 

Now we have to use a different type of strategy to finish the 

top freeform surface.  

� Click on the Create Operation icon  in the Toolbar 
 

� Then click on the FIXED_CONTOUR icon as shown in 
the figure 

 

� Choose PROGRAM for Program 
 

� Choose WORKPIECE for Geometry 
 

� Keep the default name of program 
 

� Click OK 
 

� On the parameters window, under Drive Method, select 
BOUNDARY even if it is already shown 

 

 

 

� Click on the Spanner icon as shown in the figure above 
to open the Boundary Drive Method menu 

 

� On the Create Boundary window, change the Mode to 
CURVES/EDGES 

 

� Select the Material Side to be OUTSIDE 
 

� Select the Tool Position to be ON 
 

The tool position determines how the tool will position 

itself when it approaches the boundary member. Boundary members may be assigned one of 

three tool positions: On, Tanto, or Contact. 
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• In ON position, the center point of the tool aligns with the boundary along the tool axis or 
projection vector.  

• In Tanto position, the side of the tool aligns with the boundary.  

• In Contact position, the tool contacts the boundary. 
 

� For the Plane, choose USER-DEFINED 
 

� Again, set the plane to be XC-YC = 3 
 

� Click OK 
 

� Select the outer loop of the top contour surface as shown in the figure. Remember to select 
the edges in a continuous order. 

 

 

� Click OK 
 

We have trimmed the geometry outside the loop. Now we 

have to trim the geometry inside the inner loop so that the 

only geometry left will be the area between the two loops.  

� Choose the Mode to be CURVES/EDGES 
 

� Choose the Material Side to be INSIDE and Tool 
Position to be ON 

 

� Choose the plane to be user-defined at XC-YC = 3 
 

� Select the inner edges of the contour surface as shown 
 

� Click OK to return to the Boundary Drive Method window 
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� Change the Stepover method to SCALLOP and enter the 
height to be 0.001 and click OK 
 

� Click on Cutting Parameters 
 

� Change the Tolerance values so that the Part Intol and 
Part Outtol is 0.001 

 

 

 

 

 

 

� Click on the MORE tab button and enter the value of Max Step as 1.0  
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� Click OK 
 

� Click on the FEEDS AND SPEEDS icon on the 
parameters window 
 

� Enter the parameters as shown in the figure on right 
 

� Click OK 
 

In the main Parameters window,  

� Create a new tool and name it BEM10 
 

� Change the diameter to be 10 mm and the lower radius to 
be 5 mm. 
 

� Click OK 
 

� Generate the program  
 

The contour surface is now finished and you can view the simulation by Tool Path verification.  

 

 

10.4.5 Flooring 

Flooring is the finishing operation performed on the horizontal flat surfaces (Floors) of the part. 

In most of the milling processes, flooring will be the final operation of the process. All the 
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horizontal surfaces have to be finished. This planar operation runs the cutter in a single pass on 

every face.   

� Click on the Create Operation icon  on the 
Toolbar 
 

� Change the Type to be mill_planar at the top of the 
window 
 

� Change all the options as shown in the figure 
 

� Click OK 
 

� In the parameters window, change the Cut Pattern to 
be Follow Part  
 

� Change the percent of the tool diameter for Stepover 
to be 40  

 

 

 

 

 

In flooring operations, it is always better to keep the Stepover value to be less than half of the 

diameter of the cutter in order to achieve more flatness on the planar surfaces.  

Unlike previous programs, we have to select a cut area.  

� Click on the Specify Cut Area tab  
 

� Select the highlighted surfaces shown in the figure 
below. 
 

In case you are not able to select the surfaces as shown go 

to Part Navigator and Hide the Blank, select the surfaces 

and Unhide the Blank again. 
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� Click OK 
 

� Click on CUTTING PARAMETERS in the main parameter window 
 

� Choose the STOCK tab button and enter the Intol and Outtol values as shown in the figure 
 

 

� Click OK  
 

� Click on FEEDS AND SPEEDS  
 

Because this is a Flooring operation, it is better to make the spindle speed high and the feed rates 

low compared to the previous operations.  
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� Enter the values exactly as shown in the figure 
 

� Choose OK  
 

In the main Parameters window,  

� Create a new tool and name it BEF105 
 
� Change the diameter to be 10 mm and the lower radius 

to be 5 mm. 
 
� Click OK 
 
� Generate the program. Then replay and verify the cutter 

path 
 

The following figure shows the ToolPath display for the 

flooring. 

 
 

10.5 POST PROCESSING 
 

The primary use of the Manufacturing application is to generate tool paths for manufacturing 
parts. Generally, we cannot just send an unmodified tool path file to a machine and start cutting 
because there are many different types of machines. Each type of machine has unique hardware 
capabilities, requirements and control systems. For instance, the machine may have a vertical or 
a horizontal spindle; it can cut while moving several axes simultaneously, etc. The controller 
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accepts a tool path file and directs tool motion and other machine activity (such as turning the 
coolant or air on and off).  

Naturally, as each type of machine has unique hardware characteristics; controllers also differ in 
software characteristics. For instance, most controllers require that the instruction for turning the 
coolant on be given in a particular code. Some controllers also restrict the number of M codes 
that are allowed in one line of output. This information is not in the initial NX7 NX tool path. 
Therefore, the tool path must be modified to suit the unique parameters of each different 
machine/controller combination. The modification is called post processing. The result is a post-
processed tool path. 

There are two steps involved in generating the final post-processed tool path.  

1. Create the tool path data file, otherwise called CLSF (Cutter Location Source File).  
 

2. Post process the CLSF into Machine CNC code (Post processed file). This program reads 
the tool path data and reformats it for use with a particular machine and its accompanying 
controller. 

 

10.5.1 Creating CLSF 
 

After an operation is generated and saved, the 
resulting tool path is stored as part of the operation 
within the part file. CLSF (Cutter Location Source 
File) provides methods to copy these internal paths 
from the operations in the part file to tool paths within 
the CLSF, which is a text file. The GOTO values are a 
"snapshot" of the current tool path. The values 
exported are referenced from the MCS stored in the 
operation. The CLS file is the required input for some 
subsequent programs, such as postprocessors. 

� Click on one of the programs that you want to post 
process in the Operation Navigator 
 

� Click TOOLS → OPERATION NAVIGATOR 
→ OUTPUT → CLSF 

A window will pop up to select the CLSF Format.  

 

� Choose CLSF_STANDARD and enter a location 
for the file 

 

� Choose OK 
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The CLSF file will be created. It will be similar to the figure below. The contents of the file 
contain the basic algorithm of the cutter motion without any information about machine codes 
and control systems. This file can be used for post-processing any machine control. The 
extension of the file is .cls (XXX.cls). 

 

 

 

Any program that has been output to CLSF or post-processed will have a green checkmark next 

to it in the Operation Navigator.  
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10.5.2 Post-Processing 
 

Click on a program in the Operation Navigator that you want to post process.  

� Click TOOLS → OPERATION NAVIGATOR → OUTPUT → NX 
POSTPROCESSING  

 

� Select the MILL_3_AXIS machine and enter a location for the file 
 

� Select OK 
 

This will create the post-processed file for the desired machine. You can find the block numbers 

with G and M codes concerning the Machine controller type. The extension of the file is .ptp 

(XXX.ptp).  

 

 

 

The final output (XXX.ptp) file can be transferred to the machine through DNC or punched tapes 

and the actual milling operation be done. This entire sequence starting from the transfer of the 

model into the Manufacturing module to the transfer of the files to the machine and cutting the 

raw piece into the final part is called Computer Aided Manufacturing.  

 

 


